Driver set N/A?

I’m fairly new to Linux and brand new to Endeavour, so I’m curious how is it that my wlan drivers aren’t being picked up?

When I run:
inxi -Na

I get this:

  Device-1: Intel vendor: Rivet Networks driver: N/A modules: iwlwifi
    port: N/A bus-ID: 0000:00:14.3 chip-ID: 8086:51f1 class-ID: 0280

hello @RickyFoots,
welcome to the purple universe :enos: :enos_flag: :penguin_face: :rocketa_purple:

what you have under modules is your driver, a so-called “kernel module”.

I see… Well thank you for the help!
Unfortunately that just means I no longer know why my WiFi adapter can’t be found.

What does this show?


ID TYPE      DEVICE              SOFT      HARD
 0 wlan      acer-wireless  unblocked unblocked
 1 bluetooth acer-bluetooth unblocked unblocked
 2 bluetooth hci0           unblocked unblocked

Are you dual booting with Windows?

I am not.


sudo modprobe iwlwifi

1 Like

I tried it twice and got nothing?

check if your wifi is working

ip link

It is.
I’m using my ipad to watch youtube while I try to figure this out.

Totally misunderstood that statement :sweat_smile:

[ricky@InkandQuill ~]$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s20f0u2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether 7e:82:06:5b:25:21 brd ff:ff:ff:ff:ff:ff

Looks like it’s working?

Well I wish it’d tell the rest of my computer that. I have my phone plugged into my computer and I’m tethering it to get a connection, but every time I open up my settings and search for the WiFi it tells me “No Wi-Fi Adapter Found”

Did you try rebooting again?

Yep, I have rebooted and I have made sure that both fastboot and secureboot turned off.

What is the hardware? Is this a laptop or desktop?

It’s a laptop, the Acer Swift X 14:

You could try removing the module and then adding back.

sudo rmmod iwlwifi

sudo modprobe iwlwifi

Are you sure there isn’t an F key to turn on WiFi?