Drive ext4 bad superblock

It’s the second time I have an error like this with two different drive and even one new !
The only thing this two drives have in common is that I use them on a new machine with endeavour sway edition.

Suddenly one day I decrypt the drive (luks encryption), it works then when I try to mount it I got that:
can’t read superblock at adress /dev/mapper/name

So I try:
sudo fsck.ext4 -v /dev/mapper/name
/dev/mapper/name : clean, 46080/122332032 files, 304704905/488374272 blocs

And the drive doesn’t show up (with lsblk or on gnome disks) anymore unless I reboot.

I’m not sure where to look or what to look for.


Could be a failing disk, could just be a corrupt superblock.

This may help.

If the drive contains important info, image back it up first, using dd or equivalent.

1 Like

Thank you,
but I already use fsck.ext4 and as I wrote it, it only give one line:
/dev/mapper/name : clean, 46080/122332032 files, 304704905/488374272 blocs

and then no more drive.

It’s strange that I have two disks that just got the same error and one of them I bought this year !

Did you read the link?

You need to run

sudo mke2fs -n /dev/mapper/xxx

to get any superblock backup block numbers.

Then run

sudo e2fsck -b block_number /dev/mapper/xxx 

with one of the backup superblock block number list above.

I’ve done this a few times with old drives with corrupt superblocks, and it has worked.

1 Like

Thank you,
I found the problem finally, it was a silly one, my sata cable was faulty !
The drive ceased to function when I was trying to access the partition therefore the mount command can’t found the superblock :slight_smile: .

1 Like