Doubt about and Autodesk Maya

Hello everyone,

This is my first time here, I have had EOS for about 6 months now and I really like it, I came from Ubuntu (6 months too) and previously Windows for many years and I am very happy with it!
So far I have been able to run everything I have tried and it all works nicely!

I use Autodesk Maya for work, and I installed it using this script I found on github and it seems to be working nicely.

The problem:
Maya is bundled with a python interpreter called “mayapy”, which has certain libraries built in to it that allows you to run a Maya session from the terminal. In order to do so you have to import the python library called maya.standalone as a first step, but when I do so I get this error:

Python 3.9.7 (heads/adsk-contrib-maya-v3.9.7-dirty:e6c0a2c880f, Sep  7 2021, 11:04:36) 
[GCC 9.3.1 20200408 (Red Hat 9.3.1-2)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> from maya import standalone
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: cannot open shared object file: No such file or directory

It seems to be this library missing, which I tried to install from rpm and other sources, but failed to do so, do you guys have a suggestion?

Thank you for your time in advance,

Kind regards,

Hey uikokahonia,
From the Terminal, before you start the Python-Interpreter, set the PATH-Variable from the OS like this:

$> PATH=$PATH:/your/path/to/the/libfile

Then try again.

1 Like

Welcome to the EndeavourOS forum. I hope you enjoy your time here.


1 Like

Thank you very much amarkuni for your quick response :slight_smile:
I tried that, but it didn’t work. Just so you know how I installed this library (in case I did something wrong):

The rpm file is the following:

$ cd /folder/with/rpm
$ jbigkit-libs-2.1-23.el9.aarch64.rpm
$ PATH=$PATH:/folder/with/rpm/usr/lib64/
$ PATH=$PATH:/folder/with/rpm/usr/
$ PATH=$PATH:/folder/with/rpm/
$ ls /folder/with/rpm/usr/lib64

$ /usr/autodesk/maya2023/bin/mayapy 
>>> import maya.standalone
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: cannot open shared object file: No such file or directory

I added several folders to PATH because I didn’t know whether it was the folder containing the so file or the parent folders, but none worked.

Maybe I have to rebuild/install Maya now that I have that lib?

Thank you for your time :slight_smile:

Kind regards,

Have you tried installing libjbig-shared from the AUR:

No idea if that’s it, but it seems like it might be.

Yes, I tried it at the begining, but it didn’t work, that’s why I looked at the rpm one :s.l, but thanks for the suggestion! :smile:

In what way did it not work?

Have you looked at the comments on the AUR package page?

It did not work as in I still get the same error when attempting to import maya.standalone within the python session, even if I add the AUR lib to the $PATH.
I just read the comments on the AUR package, but I don’t know how are they helping as the maintainer already added the changes they are talking about.
It also say that it provides but the error is asking for

Kind regards,

Apparently that library existed all along in the Maya lib folder, so I can imagine it was not about it being missing, but not being found.

$ ls /usr/autodesk//maya2023/lib | grep libj

And simply doing this did the trick:

export LD_LIBRARY_PATH=/usr/autodesk/maya2023/lib

Now, should I do this for every session? or should I make this variable permanent? I have read that it is not great to make it permanent so maybe I can make a sh script where I export this variable before launching mayapy?

Kind regards,

1 Like

Hopefully this article will provide some insight:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.