Double Commander (doublecmd) does not trigger dark mode

Hi, I am on Wayland on Gnome and the Double Commander does not trigger dark mode when the dark theme is selected. It works fine on PopOS and (too bad it works on Windows though)
Do you have any idea, how to trigger the dark mode in doublecmd? Thanks

Today I learned: Double Commander has a dark mode.

Stumble: Enabling it in Double Commander only works under Windows. Now to find out how to enable dark mode in Budgie.

Thanks for the information!

Like I pointed out, it works in PopOS Gnome (Ubuntu derivate) too. If it did not, I would not write the question.
The thing is I migrated to EndeavourOS and this is the first problem I could not solve.

There are three flavors of doublecmd in the Arch repo: gtk2, qt5, and qt6. Which one did you install?

I’m not sure about Gnome, but this could be caused by the fact that Gnome’s theming applies only to gtk applications only (I could be wrong about this). For the theming of QT apps, you probably need some external configuration tools like kvantum or qt5ct.

Maybe because the doublecmd in PopOS’s repo is the gtk flavor?


Do you mean when you select the dark theme in the app itself? Or do you mean you set Gnome’s global theme to a dark theme?

Since I have gnome, I installed doublecmd-gtk2 from the repo. I know that gnome = gtk :slight_smile:
By the selection I mean “gnome global theme”. There is no option in the app anyway.
In the PopOS it worked out-of-the-box. Here I struggle.

The gnome theme that you set with Gnome’s GUI probably applies to gtk4 applications only. Since doublecmd is a gtk2 application, you probably need to specify the theme for gtk2 applications by creating a .gtkrc-2.0 file inside your home directory.

First find out the name of your theme.

Then, create the file mentioned above:

$ touch $HOME/.gtkrc-2.0

Then, using your editor, add the an entry that specifies the gtk theme into that file. For instance, on my system, the file looks like this:

gtk-font-name = "Noto Sans 12"
gtk-theme-name = "Matcha-azul"
gtk-icon-theme-name = "Papirus"
gtk-cursor-theme-name = "Bibata-Modern-Classic"
gtk-cursor-theme-size = "22"

To see all the options that can be included in the file, you can refer to /usr/share/gtk-2.0/gtkrc.

Hello and welcome,

Try a theme that support GTK2, Dracula for example.

yay -S dracula-gtk-theme

@anthony93 method did not work. So I tried reproduce the PopOS setup starting with the theme.

yay -S pop-gtk-theme

The theme selection via Gnome extensions “User Themes” does not work for dark theme in the DC, but this does:

gsettings set org.gnome.desktop.interface gtk-theme Pop-dark

and the DC somehow runs in dark mode right after entering the above command.
And yes, it works with the Dracula theme gsettings set org.gnome.desktop.interface gtk-theme Dracula as well. Thanks for the hint, @vazicebon.
I tested it on X11 and Wayland. But one thing is clear - the DC completely ignores global gnome dark-light setting from the top right quick menu.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.