DOOM Eternal hardware clock related issues when trying to play multiplayer

I’m having this issue where DOOM Eternal refuses to let me play multiplayer because of what I assume is a hardware clock related issue. I had this on Windows as well and fixed it by syncing the hardware/BIOS clock to the system clock, tried doing the same thing on my EndeavourOS system with hwclock but to no avail. Would appreciate some help or to just know if someone else had this issue before.

Tried asking Bethesda support but its Bethesda, it was useless.

What did you run, in the Archwik it mentions to run the following to sync the hardware clock?
# hwclock --systohc
And it can be useful to have an ntp client running, not sure if that is installed by default on EndeavourOS.
I just tried playing multiplayer with Doom Eternal and it just works for me.

Yeah, I ran

hwclock --systohc

and it did sync them up but I’m still having the issue. I’m not sure if its some other issue possibly, but as mentioned I already had this same issue and fixed it on Windows which is why I suspect its the same problem. Might try running a live USB of a distro and see if it still has the same problem. Thank you for the quick response by the way

Check if Chrony is installed by running the following.
systemctl status chronyd
If that doesn’t return a status output then it is not installed. Then it might be worth a try to install and enable it since Chrony does time synchronization.

pacman -S chrony
systemctl enable chronyd --now

Then see if you still have the same problem when trying to launch multiplayer with Doom Eternal.

Yup, chrony is running, unfortunately didn’t help