Dolphin, VLC, Samba video playback fix

If you are like me, I use VLC to play videos back on my Linux install. I use KDE Plasma, and about 6 months ago or so, I started having issues playing videos back from my network shares, which use the Samba protocol, via Dolphin. Sometimes the video would play, and sometimes the video would not play and VLC would error out. The fix is really easy.

The Cause:

This is caused by a change in VLC’s prefetch values as it relates to streaming video. With version 3.0.8, the devs of VLC changed the default values.1 While this does not affect other file managers such as Thunar, Caja, and Nautilus, it does prevent video playback from Samba shares via Dolphin.

The Solution:

We need to change the prefetch values used by default in VLC.

  1. Open VLC

  2. Go To Tools>Preferences

  3. In the Show settings box, select the All option.

  1. In the Input / Codecs section, look for the Stream filters options and click on it.

  2. This will open the Stream prefetch filter options.

  1. Change the value in the Read size box to match the Buffer size value.

  1. Hit Save and restart VLC.

Now VLC will playback videos that are stored on Samba shares without any issues.



Hey …i like that background you got going on!

1 Like

This seems illogical. You should rather increase the buffer.

1 Like

@ricklinux Thank you. It is an old Carlsberg beer advertisement. It combines two of the three favorite things after computers. Beer and Space.

@axt I know it seems illogical. That is why it took me a while to track down what was going on. If you increase the buffer size, You get the same errors. I think it has something to do with how Dolphin accesses Samba shares and passes credentials on to other programs. This problem is ONLY present when one uses the combination of Plasma, Dolphin, Samba, and VLC. When you bring it up to the devs, they point at the OTHER program and say it is their fault.

Other than needing a “Doctoral Degree in Pretzel Logic” to understand the Plasma System Settings, this is the only complaint I have had with Plasma since switching to it from Gnome.