Dolphin Issue

When access folders on my NAS that have multiple files they immediately start disappearing and usually am left with only one visible file. I noticed it only happens when I move the mouse over the file folder. So it has something to do with the mouse? This does not happen on files on the local computer only on the NAS. I never seen this happen before. This is a new installation of EndeavorOS KDE. Please advise.

What if you use a different file manager? I do not have that happening looking at my Synology using PCManFM or the default Nemo.
I use Cinnamon instead of KDE, in case that plays into it.

I installed PCManFM and it works fine, no issues with phantom files. The laptop in question has NVIDIA Prime and for a long while I was only able to get Kubuntu working well on it with little or no hassle. It even configure NVIDIA well. Wish I did not have the dual video( Intel, NVIDIA), only recently has it become somewhat easier to configure for me but not totally stable. I decided to try EndeavourOS and got the phantom file issue in Dolphin. I then tried Opensuse Tumbleweed today and got the same issue in Dolphin. Not sure what to make of it, but appreciate your help.

1 Like

off the top of my head in the solus forums the kde/dolphin/nas thing was a known problem and remedied by editing fstab and a general PITA until dialed in. as for more info, I’ve never run kde. just recalling. [too much forum reading; maybe I need to ‘touch grass.’]

also just installed lxde and I found native pcmanfm so loathsome a file manager, with so many limitations, that I switched to nemo seamlessly. --I only wrote this in case you soon find it loathsome too. I don’t know if you could get away with nautilus in kde but just speculating

I use thunar as my secondary file manager. I had use Nemo but found Thunar was beter for my use.

How are you accessing the folders though. What protocol?

I run Thunar using sudo from the terminal, but only when I need root access to multiple files. I find it easier than opening Dolphin as admin.

I don’t have a solution.

Seems like a weird flickering issue with Dolphin and wayland and nvidia. I have no problem with Dolphin, but see some weird flickering like this in chrome based browsers. (I don’t know of any fix yet)

Also happened on Mullvad, but fixed it with an environment variable MOZ_ENABLE_WAYLAND=1 in Environment Variables: by right clicking the app in the menu Edit Application (Edit Program?) → Application (Program?) and adding the environment variable. Could there be a similar variable for Dolphin with wayland?

Edit: Do you have dolphin-plugins installed?