Does endeavourOS use the latest versions of the software packages?

Hi.

First of all, thank you for this wonderful project!

I am just getting started with it and my only question is about the software packages - are they the latest version (bleeding edge), closest to the Arch model?

If not, is there an average time that passes form the day a new version of a software is available to it being released in the repositories that you use?

Thank you very much in advance for your help :slight_smile:

Well - they roll with Arch so yes. I have laptops with Arch and Endeavour and the updates are available at the same time

2 Likes

EOS uses Arch repos directly, so packages are as new as Arch has.

And welcome aboard!

1 Like

Thank you all for the warn welcome!

I tried to test endeavouros on a virtual machine but it turns out that my current configuration conflicts with VirtualBox so i couldn’t test the OS.

If the image is hybrid (both live mode and installation mode) I will try to put the image onto a USB drive. Will reckon that either Rufus or Etcher will do the job just fine.

Thanks again to you all for your help!

Let me guess! The virtual graphics controller:wink:

Hi.

I wish it was that :slight_smile:
What i think happens is that there is a conflict between VirtualBox and Windows 10 itself that prevents me from configuring virtual machines in the first place.

It should have something to do with Hyper-V or Windows Sandbox… Even though i tried disabling these features, the virtual machine won’t start.

I can try installing endeavourOS on an external drive and hope that i won’t break the system soon because i won’t be having the snapshot feature to help me :smile:

However the bleeding edge repos combined with the welcoming GUI and light system resource usage convinced me to try it.

I am not that an advanced of the Linux command line, but the fact that endeavourOS is so customizable really had me want to try it.

If this won’t have me learn Linux in depth, I don’t know what will. :laughing:

I tried several distros, but the only ones that got me stuck during installation is Arch Linux and LinuxFromScratch.

So endeavourOS is my hope of bridging this gap for myself.

Nevertheless, I will try the solution you linked here, who knows, may just be the cause and i don’t know it yet.

Will soon find out

This can do:
http://www.linuxcommand.org/tlcl.php/
:slight_smile:
Free ebook, one of my first in-depth command line books, written in such nice way that I think everyone would understand. Very, VERY good point to start learning linux, trying to hop into advanced/semi-advanced targeted distro may actually discourage one :wink:

Just tried or actually performed? Yes, if you don’t disable Hyper-V in Win10 LTSB, VBox won’t work.

  1. Push [super] (the Windows Key)!
  2. Type cmd!
  3. Start with administrative rights!
  4. execute: bcdedit /set hypervisorlaunchtype off
  5. Reboot!

Now you could start VBox VMs.

If you want to undo this (if you don’t want to use VBox anymore), run bcdedit /set hypervisorlaunchtype auto!

1 Like

If it wasn’t there either (alone), the concrete error output would make sense (otherwise we advise unnecessarily).

It should be clear that in the BIOS or UEFI VT-x (Intel) or AMD-V must be enabled and the CPU must contain VT-x or AMD-V.

None of the links works for the book.

Hi.

I’ve managed to download the book myself so i will attach a link to it here

Link to download the book (valid for 30 days)