Display weird behavior (resolution?) on startup. Messed up screen

Hello,
First of all, thanks a HUGE lot for that wonderful distro!!
I’m already sorry cause i dunno if i should post here or in bug section, or noob or… “try harder”? :stuck_out_tongue:
I’ve browse several leads to try to “fix” my problem, unsuccessfully…

So, here’s the story…
I have an install on an HDD, works fine.
Bought an SSD (NVMe), installed on it → display mess on startup (after grub, starting at the login screen (lightdm i guess))
Got another SSD (SATA)(not at all because of that indeed), installed on it → same problem with displayed screen resolution (or is it?)

Well, i don’t think the kind of drive have anything to do with it indeed, probably installation related.

So, as you can see on pictures, the display “switch” to that weird resolution on startup, after choosing an grub entry, when the login screen appears, and stays like that… seems to be consistent on each startup with the last install, but was more random (sometimes no problem with the display) on the previous one.


Anyway, a workaround is to put the computer to sleep, then wake it up, and everything is fine, no more weird distortion on the screen. This “solution” works perfectly…

If anybody could lead me to where I should investigate… it would be so sweet and MUCH appreciated !!!

Cheers !

system overview : http://ix.io/3loY

1 Like

Is xf86-video-intel installed? We could also use the output of inxi -Fxxxza --no-host

1 Like

Hi

Yes xf86-video-intel is installed

That would be the output of inxi -Fxxxza --no-host

System:
  Kernel: 5.11.16-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux 
  root=UUID=f1b34ed7-ffb1-4419-a9af-79c4cbb1d5fc rw rootflags=subvol=@ quiet 
  cryptdevice=UUID=8b0ef476-4f7f-414d-88a9-5ac163cee376:luks-8b0ef476-4f7f-414d-88a9-5ac163cee376 
  root=/dev/mapper/luks-8b0ef476-4f7f-414d-88a9-5ac163cee376 loglevel=3 
  resume_offset=1756228 nowatchdog 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux 
Machine:
  Type: Laptop System: HP product: HP Laptop 15-da0xxx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: HP model: 84A6 v: 80.48 serial: <filter> UEFI: Insyde v: F.35 
  date: 12/09/2020 
Battery:
  ID-1: BAT1 charge: 39.3 Wh (100.0%) condition: 39.3/41.0 Wh (95.6%) 
  volts: 12.9 min: 11.4 model: Hewlett-Packard PABAS0241231 type: Li-ion 
  serial: <filter> status: Full 
CPU:
  Info: Dual Core model: Intel Core i3-7020U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: E0 cache: L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 18406 
  Speed: 800 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 790 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300 
  Device-2: Cheng Uei Precision Industry (Foxlink) HP TrueVision HD Camera 
  type: USB driver: uvcvideo bus-ID: 1-5:2 chip-ID: 05c8:03ba class-ID: 0e02 
  serial: <filter> 
  Display: x11 server: X.org 1.20.11 driver: loaded: intel 
  unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.0.3 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d71 class-ID: 0403 
  Sound Server-1: ALSA v: k5.11.16-arch1-1 running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel modules: r8168 port: 4000 
  bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter 
  vendor: Hewlett-Packard driver: rtw_8723de v: N/A modules: rtw88_8723de 
  port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:d723 class-ID: 0280 
  IF: wlan0 state: up mac: <filter> 
Bluetooth:
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb 
  v: 0.8 bus-ID: 1-6:3 chip-ID: 0bda:b009 class-ID: e001 serial: <filter> 
  Report: bt-service: disabled note: bt-adapter can't run. 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086.282a rev: 21 
  class-ID: 0104 
Drives:
  Local Storage: total: 585 GiB used: 12.17 GiB (2.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LM030-1RK17D 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: RSM8 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: RBU-SNS8100S3128GD 
  size: 119.24 GiB block-size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 06.9 scheme: GPT 
Partition:
  ID-1: / raw-size: 70.79 GiB size: 70.79 GiB (100.00%) 
  used: 12.17 GiB (17.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-8b0ef476-4f7f-414d-88a9-5ac163cee376 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 2 MiB (0.4%) fs: vfat dev: /dev/sdb3 maj-min: 8:19 
  ID-3: /home raw-size: 70.79 GiB size: 70.79 GiB (100.00%) 
  used: 12.17 GiB (17.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-8b0ef476-4f7f-414d-88a9-5ac163cee376 
  ID-4: /var/log raw-size: 70.79 GiB size: 70.79 GiB (100.00%) 
  used: 12.17 GiB (17.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-8b0ef476-4f7f-414d-88a9-5ac163cee376 
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 6 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swap/swapfile 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 28.5 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 221 Uptime: 17m wakeups: 3 Memory: 3.75 GiB 
  used: 1.57 GiB (41.8%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 10.2.0 Packages: pacman: 866 lib: 211 Shell: Bash v: 5.1.4 
  running-in: xfce4-terminal inxi: 3.3.03

Thanks !

1 Like

You could try to remove it as it sometimes causes issues like this. I wouldn’t without a back-up plan. I can’t guarantee you wont reboot into a black screen.

1 Like

Removing the package lead to: failed loading light display manager
Can’t boot :confused:

So you still have the USB installer?

1 Like

yes i do.
but i installed using this sweet! tuto so it seems very easy to roll back to the previous state :slight_smile: (if that was why…)

1 Like

Unless you’ve seen this already, it might help:
https://wiki.archlinux.org/index.php/Intel_graphics

1 Like

I’ve seen it, thanks a lot, i don’t know if i tried the right troubleshooting, i did try TearFree and the Screen flickering without success. i also tried to force keeping the resolution in grub config as describe in the installation guide.
Maybe i should try more “tweaks” in the modprobe…

It’s weird cause i still have the up to date Endeavour HDD install on that machine and never had this problem with it.

Some graphics related or kernel updates may sometimes cause trouble.
Have you tried using the LTS kernel?

1 Like

yep unfortunately i did :frowning:

it’s also weird that asa it’s put to sleep and resume the screen is fine again.
i don’t really get what it’s doing, looks like it’s trying to display the correct resolution (or not…) on a “bigger” screen than it is (the bottom and right parts are outside the screen, not sure the pictures show that well) [edit: only the right part of the display is missing, height looks ok…euh, well it doesn’t ^^ ]

Not sure if it helps anything, but changing display manager to sddm might be worth trying.
But more probably some graphics driver related setting or kernel parameter could help.
I’m not good at them, so hopefully someone with more insight will help.

Oh, Rick is coming this way! :slight_smile:

1 Like

Have you tried adding i915 to the MODULES=" " section in the /etc/mkinitcpio.conf

1 Like

hey, thank you all for your help, much appreciated!

so i915 wasn’t in the MODULES section of mkinitcpio.conf
I did add it (so the line would look like that: MODULES="crc32c-intel i915"
rebooted

and it is still the same behavior :’(

Okay I don’t think it will hurt having it anyway. Maybe try some kernel parameters such as

i915.enable_psr=0

You can add that to the default grub command line in /etc/default/grub and update grub with
sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

i can’t remember if i tried it before, so i just did add the line and rebooted

→ still no luck :confused:

i guess i’ll try other kernel instructions (and combinations of it) as described in the endeavour installaion guide. (i think i did)

and @manuel i will try sddm right now (i tried some other dm, can’t remember if all of them)

Well if you are game i think you’ll need to try some other kernel parameters

i915.enable_rc6=0

1 Like

i tried some of them (the exemples listed in endeavour guide at once (is that a mistake ?) with no results.

i have to check sudo modinfo -p i915 for the complete list

well, still no luck

No i don’t think it hurts but if you find something that works then you’d have to remove one at a time to figure out which one is the correct one. I’m sure there could be conflicts also but you’d probably see that in a hurry. Usually removing the fx86-video-intel is what works. But you need to be running on the kernel module not the Intel so you would need to make sure it’s not loading intel. Have you tried nomodeset?

1 Like