Display set to "Unknown-1" after reboot, and second monitor not displaying

Hello!! I’m VERY new to Endeavour and Linux in general, and I was trying to configure my system for gaming, and after a reboot, my second monitor is not recognized, and my primary display is set to 1024x768 (supposed to be 1440p) with a name of “Unknown-01” (supposed to be LG Ultragear). I tried looking in some other threads, and reinstalling the Nvidia drivers, and then tried reinstalling steam, but so far I have not had any luck. Hoping to see if this is a known issue/hurdle!!

I’ve been doing some digging on the forums already, and have seen a few people ask for the output of inxi -Ga, so I’m posting that below as well.

  Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] vendor: ZOTAC driver: N/A
    alternate: nouveau non-free: 550.xx+ status: current (as of 2024-06;
    EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
    built: 2020-2023 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:2482 class-ID: 0300
  Device-2: AMD Raphael vendor: Micro-Star MSI driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-1, DP-2,
    DP-3, HDMI-A-1, Writeback-1 bus-ID: 10:00.0 chip-ID: 1002:164e
    class-ID: 0300 temp: 41.0 C
  Display: wayland server: X.org v: with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: amdgpu,modesetting
    alternate: fbdev,nouveau,nv,vesa dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: Unknown-1 res: 1024x768 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi
    wayland: drv: swrast x11: drv: swrast
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: mesa v: 24.1.3-arch1.1 glx-v: 1.4
    direct-render: yes renderer: llvmpipe (LLVM 18.1.8 256 bits)
    device-ID: ffffffff:ffffffff memory: 29.82 GiB unified: yes
    display-ID: :1.0
  API: Vulkan Message: No Vulkan data available.

It appears that my system isn’t recognizing a driver? I’m not sure how to go about fixing this though! Any help would be greatly appreciated.

Thank you!!

Greetings @Scamper ! :wave: :sunglasses: :enos_flag:

Yes it would seem you’re missing your Nvidia driver.

Can you share the output of this please (it will list packages currently installed with “nvidia” in their name):

yay -Q | grep nvidia

Can you post the full output of your hardware? Post the url

inxi -Faz | eos-sendlog