Display only show up with 30Hz


i currently testing using my Xiaomi 4K Home Cinema Laser Projector as additional Display to play games on when friends come over, but it only offer me 30Hz in the settings.

Here are a few informations about my current setup:
OS: Endeavour OS with KDE
GPU-Driver: official one from nvidia, installed by endeavour

  • Primary: DELL G3223D connected via DP
  • Secondary: mentioned projector connected via HDMI

I already tried to add a new mode manually with xrandr, but it only shows me the following error:

xrandr --addmode HDMI-0 "3840x2160_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  43
  Current serial number in output stream:  44

For reference, here are the commands with the output i used to create that mode:

cvt 3840 2160 60
# 3840x2160 59.98 Hz (CVT 8.29M9) hsync: 134.18 kHz; pclk: 712.75 MHz
Modeline "3840x2160_60.00"  712.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync

xrandr --newmode "3840x2160_60.00"  712.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync

I also verified the cable and the projector, unfortunatly i only could test the cable against a 2k@144Hz Monitor, but both worked without a problem (projector tested against Apple TV 4K)

After looking online i couldn’t find a fix for that, so i hope someone here is able to help a new user !

i also tried to post the output of nvidia-bug-report.sh, but it is to big

short update: i tried it with a endeavour live system to check if i messed up a setting maybe, but there is the same problem.

I assume you added an undetected resolution? After adding an undetected resolution you must also change the resolution to the one added? Just in case you missed something.


Thank you for the response, but i can’t even add the resolution, also xrandr --output doesn’t change the resolution at all :confused:

After trying to add the newmode did you also specify what connection afterwards.

xrandr --addmode HDMI-0 "3840x2160_60.00"

Edit: It is possible the EDID modes are not being read properly.


You could also try adding Option "UseEDID" "FALSE" to the an xorg file which you would have to create since i don’t think it has it with nvidia.



yep i specified the connection, but there i got the issue mentioned in my initial post.
I seen an error that it couldn’t read the EDID properly in the nvidia-bug-report.sh output.

Can i simply create the xorg.conf file with just the option mentioned by you in it, or do i need to do something additional to that, because currently i dont have a xorg.conf file at all in the /etc/X11 folder.

Thank you for the response

Yes… you could try creating an xorg file with nano. Nvidia doesn’t create it normally. I would follow by this arch wiki guide. Put the options and settings based on your hardware. You may want to specify each monitor with it’s own settings. With the projector try the option i suggested. Not sure it will work but you could try and after you may have to add the modes? I’m not sure i just saw this on a post on reddit. I’m not an expert just giving some ideas.


thank you, i will try it tomorrow after my work and will give a update :slight_smile:

Not sure if this is helpful also regarding creating and using a custom EDID. What i mentioned above was using the xorg file and option to have it not use the EDID since it either can’t read it or is incorrect.

Maybe you can peruse this information also and it may or may not help but maybe you learn something from it. As i say I’m no expert when it comes to this as you have to have the hardware and the problem in order to try to figure it out if it can be. :man_shrugging:


Edit: I know this is about using Kodi but a lot of the information is somewhat useful.

short update on this thread:
The configuration over the xorg.conf didn’t really worked.
The other mentioned possible solution with custom-edid did work someway, i was able to generate the .bin files and force xorg to use it, but it always messed up something. For example i used my modeline from my initial post and got 4k resolution, but with only 5hz, then i tried the 3840x2160.bin that also should have 60Hz but with that i got 640xsomething resolution.

Maybe someone have an idea what i’m making wrong :slight_smile: