Display not recognised by Xorg after update

Just updated my system and it broke - xrandr no longer recognizes the display, so the resolution is completely broken. xrandr claims that the highest acceptable resolution is 640 x 480. Also the status bar and start menu aren’t displayed.
When I run xrandr I get

$xrandr
Screen 0: minimum 16 x 16, current 640 x 480, maximum 32767 x 32767
Unknown-1 connected primary 640x480+0+0 (normal left inverted right x axis y axis) 169mm x 127mm
  640x480      59.38
  320x240      59.52
  640x400      59.95
  320x200      58.96
  640x350      59.77

I have an NVIDIA GeForce GTX 1080 Ti graphics card and BENQ PD3200U-T monitor.

I’ve tried setting a custom resolution, using the following commands:

$cvt 3840 2160 60
# 3840x2160 58.98 Hz (CVT 8.29M9) hsync: 134.18 kHz; pclk: 712.75 Mhz
Modeline "3840x2160_60.00" 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync
$xrandr --newmode "3840x2160_60.00" 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync
$xrandr --addmode Unknown-1 3840x2160_60.00
$xrandr --output Unknown-1 --mode 3840x2160_60.00
X Error of failed request:  BadValue (integer parameter out of range ro operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  21 (RRSet CrtcConfig)
  Value in failed request: 0x0
  Serial number of failed request: 22
  Current serial number in output stream: 22

After that, I’ve tried downgrading nvidia drivers to version 545.29.06, but it only made it so that the status bar and start menu became visible and didn’t fix the recognition problem.
Then I’ve tried downgrading plasma, but failed due to how tangled the dependencies are.

I’ve also tried changing the cable from displayport to HDMI, and changing the ports on the GPU, but that didn’t help either.

Surprisingly, the login menu displayed after booting has the correct resolution.

I’m not even sure what the problem is, since downgrading GPU drivers didn’t help, and Xrandr is DE-agnostic, so it shouldn’t be an issue with KDE.

I just had these updates. Did you also have these updates when the problem started? There was a newer version of mesa.

[2024-03-07T11:40:23-0500] [ALPM] upgraded lib32-llvm-libs (16.0.6-2 -> 17.0.6-2)
[2024-03-07T11:40:23-0500] [ALPM] upgraded lib32-libva-mesa-driver (1:24.0.2-1 -> 1:24.0.2-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded llvm-libs (16.0.6-1 -> 17.0.6-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded mesa (1:24.0.2-1 -> 1:24.0.2-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded lib32-mesa (1:24.0.2-1 -> 1:24.0.2-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded lib32-mesa-vdpau (1:24.0.2-1 -> 1:24.0.2-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded vulkan-radeon (1:24.0.2-1 -> 1:24.0.2-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded lib32-vulkan-radeon (1:24.0.2-1 -> 1:24.0.2-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded libva-mesa-driver (1:24.0.2-1 -> 1:24.0.2-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded mesa-vdpau (1:24.0.2-1 -> 1:24.0.2-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded qt5-tools (5.15.12+kde+r4-1 -> 5.15.12+kde+r4-2)
[2024-03-07T11:40:24-0500] [ALPM] upgraded qt6-tools (6.6.2-1 -> 6.6.2-2)

Yes, I’ve also updated all of these packages and I’m on the 1:24.0.2-2 version of mesa now.

Did it happen before this update or after?

After. I’ve tried downgrading to 1:24.0.2-1 but then I can’t start the DE, after I enter the password it hangs a bit and boots me back to the login screen.

I’ve rolled the whole system back using eos-shifttime, so it works properly now, but this is still an issue since there’s no guarantee that there won’t be the same problem next time I have to update

Hopefully eventually it will work itself out.

1 Like

I’m a Linux newbie, and this update broke my system too. After logging in, all I got was a blank screen. What solved my problem was realizing at the login screen that the system was starting with Wayland session when I previously used X11. I just clicked there to change it to X11 and it solved my problem. Maybe it could help you?

I’m also having issues since today’s updates. I can no longer launch steam games.