Display going to Standby Mode after some minutes of inactivity


Both Power Management and Screensaver are disabled but my display is going to standby mode. Not only that suppose I am listening to a playlist in Spotify the music stops by itself. Then when I move the mouse display comes back and the song start playing from where it was stopped.

Which settings do I need to modify to stop this ?
DE : LXQT

You posted in the Pub. Here we drink alcohol and tell jokes. If you like I can tell you a few… :rofl:

DPMS has various enemy shooters that kill it. They may come in with random packages you don’t even know they autostart. It depends on the name of the Pub as well.

1 Like

@dalto
I made a mistake of posting this thread on the Pub. Kindly move this topic to section which you think is appropriate.

System info? It looks like MATE??

$ inxi -Fxz
System:
  Kernel: 5.16.15-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: LXQt 1.0.0 Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: H110M-CS v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 3016
    date: 12/27/2016
CPU:
  Info: dual core model: Intel Core i3-6100 bits: 64 type: MT MCP
    arch: Skylake-S rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 800 min/max: 800/3700 cores: 1: 800 2: 800 3: 800
    4: 800 bogomips: 29608
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel
    bus-ID: 00:02.0
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: intel
    unloaded: modesetting gpu: i915 resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.16.15-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: e000
    bus-ID: 02:00.0
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-3:2
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:
  Local Storage: total: 260.84 GiB used: 51.5 GiB (19.7%)
  ID-1: /dev/sda vendor: Seagate model: ST3160215AS size: 149.05 GiB
  ID-2: /dev/sdb vendor: Samsung model: SSD 750 EVO 120GB size: 111.79 GiB
Partition:
  ID-1: / size: 109.18 GiB used: 41.26 GiB (37.8%) fs: ext4 dev: /dev/dm-0
    mapped: luks-819f4d3b-3d3c-4d7c-954f-a61209b731c6
  ID-2: /boot/efi size: 299.4 MiB used: 448 KiB (0.1%) fs: vfat
    dev: /dev/sdb1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 198 Uptime: 4h 23m Memory: 3.7 GiB used: 2.87 GiB (77.4%)
  Init: systemd Compilers: gcc: 11.2.0 Packages: 900 Shell: Bash v: 5.1.16
  inxi: 3.3.13

I am using LXQT. I was wrong when I wrote that audio too is stopping when using Spotify. My display just went to standby mode again but Spotify kept playing. Then when I moved my mouse display signal got restored.

Take a look here

2 Likes

:point_up_2:
this is possible … as it can also disable it fully…
And it can be display itself also… having some powersavingoptions …

Check in Autostart applications and find any other relevant utility running.
It could also be a system(d) unit, or a DBUS configuration, or a default Xorg setting.
Check autostarting apps:

# For config autostart
sudo pacman --needed -S dex && dex -ad
# For session running units
systemctl --user list-units -t service

ls /etc/xdg/autostart

will show all of the systemwide autostarting from packages…

But using dex is a nice idea and shows all aside from indeed systems services

1 Like
$ ls /etc/xdg/autostart
at-spi-dbus-bus.desktop      lxqt-globalkeyshortcuts.desktop  lxqt-powermanagement.desktop         wallpaper-once.desktop
blueman.desktop              lxqt-notifications.desktop       lxqt-runner.desktop                  welcome.desktop
eos-update-notifier.desktop  lxqt-panel.desktop               lxqt-xscreensaver-autostart.desktop
lxqt-desktop.desktop         lxqt-policykit-agent.desktop     nm-applet.desktop

So I delete powermanagement.desktop & lxqt-xscreensaver-autostart.desktop ?

they are both known applications you already setup to not poweroff display :wink:
and they would get back on each update of these applications (or reinstalling them)

@joekamprad @sandman
I have done xset s off now I will observe the system the entire day. This is quite troublesome coz I don’t exactly how many minutes to wait to confirm that it worked.

I must mention one point. This is not a mistake. I am 100% sure about this one. The point is the display doesn’t go to standby when I am watching a video using either Firefox or Smplayer.

as you say in title “a couple of minutes” it should not need that long :wink:

As I said I didn’t time it. I wrote minutes coz I am sure this takes less than an hour. Yesterday I launched Spotify, selected a playlist, when the songs started playing I manually switched off my display. After 7-8 songs I turned on my display and got “No Signal”. As soon as I moved my mouse display signal was restored.

My plan is to do the same thing today. I will play a playlist & check the display status after 30 mins.