DISP+HDMI-0 command not found | Custom Resolution error


Trying to create 1280x960 @ 60Hz. Something is wrong though. What I know not. My rational is that this television is an 1080i display that only plays well with EndeavourOS at 4:3 aspect ratios, so I decided to try creating a 1280x960 profile, because being stuck with 1024x768 sucks. I had to type this entire thing by hand, because if I don’t type the entire thing by hand, copy and paste gives me results that aren’t desirable, like copying and pasting the desired text wrong by adding all sorts of unwanted stuff to it, likely Endeavour hotkey related stuff not playing nice with my membrane keyboard.

What desktop environment are you using?

And it seems you’re trying to run part of a bash code that DISP+HDMI-0 not a command it’s part a variable.

Offline install XFCE. I don’t really know how to run it as a variable or otherwise* :confused:

One more thing. If you’re running XFCE can’t set the display resolution using setting → Display?

I can select from a very limited list of display resolutions in Display. My very aim is to hopefully add a new profile to that list because my largest available supported resolution that works is 1024x768 which is a pain. Adding a larger resolution closer to “900P” would be easier on the eyes methinks.

You have a TV, not a monitor right?

  • Open up your terminal and run gtf <resolution you want> <refresh rate> Ex: gtf 1920 1080 60

  • Above should give an output like below

# 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
  Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
  • Tale the entire part after the word *Modeline and add it after this command xrandr --newmode So the complete command would look like below.
xrandr --newmode "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
  • Now run xrandr it would show a list and it would show what out put is being used. Mine is DP1.

  • After making sure which output use us can run this command `xrandr --addmode ". Ex:

xrandr --addmode HDMI1 "1920x1080_60.00"
  • Now run this xrandr --output <Output> --mode "<profile name>"
    Ex:
xrandr --output HDMI1 --mode "1920x1080_60.00"

EDIT: You can just check the resolution if it works before doing the above steps by xrandr -s 1920x1080

$ gtf 1280 960 60

  # 1280x960 @ 60.00 Hz (GTF) hsync: 59.64 kHz; pclk: 102.10 MHz
  Modeline "1280x960_60.00"  102.10  1280 1360 1496 1712  960 961 964 994  -HSync +Vsync

$ xrandr --newmode "1280x960_60.00"  102.10  1280 1360 1496 1712  960 961 964 994  -Hsync +Vsync
$ xrandr
Screen 0: minimum 8 x 8, current 1331 x 998, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1331x998+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.05 +  60.00    59.94    29.97    23.98    60.00  
   1440x480      60.05  
   1280x720      60.00    59.94  
   1024x768      60.00* 
   800x600       60.32  
   720x480       59.94  
   640x480       59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
  1280x960_60.00 (0x2d7) 102.100MHz -HSync +VSync
        h: width  1280 start 1360 end 1496 total 1712 skew    0 clock  59.64KHz
        v: height  960 start  961 end  964 total  994           clock  60.00Hz
$ xrandr --addmode hdmi-0 "1280x960_60.00"
xrandr: cannot find output "hdmi-0"
$ xrandr -s 1280x960
Size 1280x960 not found in available modes

:anguished:

Oh you know what hdmi-0 wasn’t capitolized it seems

Yeah, that’s what the command is saying.

$ xrandr --newmode "1280x960_60.00"  102.10  1280 1360 1496 1712  960 961 964 994  -Hsync +Vsync
$ xrandr
Screen 0: minimum 8 x 8, current 1331 x 998, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1331x998+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.05 +  60.00    59.94    29.97    23.98    60.00  
   1440x480      60.05  
   1280x720      60.00    59.94  
   1024x768      60.00* 
   800x600       60.32  
   720x480       59.94  
   640x480       59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
  1280x960_60.00 (0x2c6) 102.100MHz -HSync +VSync
        h: width  1280 start 1360 end 1496 total 1712 skew    0 clock  59.64KHz
        v: height  960 start  961 end  964 total  994           clock  60.00Hz
$ xrandr --addmode HDMI-0 "1280x960_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  39
  Current serial number in output stream:  40

yea this is more familiar, I’ve had this error before

It looks like a 1331 x 998 Custom Resolution would actually be this display’s native Resolution and be better to go for. If only xrandr wouldn’t spit this error.

This article:https://askubuntu.com/questions/235507/xconfig-xrandr-badmatch looks helpful but I would need help if I were to follow along with any of the Xorg steps. Also I cannot always really tell the difference between the Xorg methods and the non Xorg methods all of the time. I have also pondered the meaning of the Badmatch invalid parameter inputs… Like, what are valid Xrandr inputs? Where are the parameters set?

$ gtf 1331 998 60

  # 1328x998 @ 60.00 Hz (GTF) hsync: 61.98 kHz; pclk: 110.08 MHz
  Modeline "1328x998_60.00"  110.08  1328 1408 1552 1776  998 999 1002 1033  -HSync +Vsync

$ xrandr --newmode "1328x998_60.00"  110.08  1328 1408 1552 1776  998 999 1002 1033  -HSync +Vsync
$ xrandr
Screen 0: minimum 8 x 8, current 1331 x 998, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1331x998+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.05 +  60.00    59.94    29.97    23.98    60.00  
   1440x480      60.05  
   1280x720      60.00    59.94  
   1024x768      60.00* 
   800x600       60.32  
   720x480       59.94  
   640x480       59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
  1328x998_60.00 (0x2b6) 110.080MHz -HSync +VSync
        h: width  1328 start 1408 end 1552 total 1776 skew    0 clock  61.98KHz
        v: height  998 start  999 end 1002 total 1033           clock  60.00Hz
$ xrandr --addmode HDMI-0 "1328x998_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  39
  Current serial number in output stream:  40

:anguished:

I just created a new VM and used your resolution to add it and it worked. Only difference is I used sudo.

This is after running the commands.

[s4ndm4n@s4ndm4n-standardpci440fxpiix1996 ~]$ gtf 1331 998 60

  # 1328x998 @ 60.00 Hz (GTF) hsync: 61.98 kHz; pclk: 110.08 MHz
  Modeline "1328x998_60.00"  110.08  1328 1408 1552 1776  998 999 1002 1033  -HSync +Vsync

[s4ndm4n@s4ndm4n-standardpci440fxpiix1996 ~]$ sudo xrandr --newmode "1328x998_60.00"  110.08  1328 1408 1552 1776  998 999 1002 1033  -HSync +Vsync

[s4ndm4n@s4ndm4n-standardpci440fxpiix1996 ~]$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
Virtual-1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080     60.00 +  60.00 +
   2560x1600     59.99    59.97  
   1920x1440     60.00  
   1856x1392     60.00  
   1792x1344     60.00  
   2048x1152     60.00  
   1920x1200     59.88    59.95  
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98    59.95  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.89    59.90  
   1280x960      60.00  
   1280x854      59.95  
   1366x768      59.79    60.00  
   1360x768      60.02  
   1280x800      59.81    59.91  
   1280x768      59.87    59.99  
   1280x720      60.00  
   1152x768      59.95  
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   720x480       59.94  
   640x480       59.94  
Virtual-2 disconnected (normal left inverted right x axis y axis)
Virtual-3 disconnected (normal left inverted right x axis y axis)
Virtual-4 disconnected (normal left inverted right x axis y axis)
  1328x998_60.00 (0x556) 110.080MHz -HSync +VSync
        h: width  1328 start 1408 end 1552 total 1776 skew    0 clock  61.98KHz
        v: height  998 start  999 end 1002 total 1033           clock  60.00Hz

[s4ndm4n@s4ndm4n-standardpci440fxpiix1996 ~]$ sudo xrandr --addmode Virtual-1 "1328x998_60.00"

[s4ndm4n@s4ndm4n-standardpci440fxpiix1996 ~]$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
Virtual-1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080     60.00 +  60.00 +
   2560x1600     59.99    59.97  
   1920x1440     60.00  
   1856x1392     60.00  
   1792x1344     60.00  
   2048x1152     60.00  
   1920x1200     59.88    59.95  
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98    59.95  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.89    59.90  
   1280x960      60.00  
   1280x854      59.95  
   1366x768      59.79    60.00  
   1360x768      60.02  
   1280x800      59.81    59.91  
   1280x768      59.87    59.99  
   1280x720      60.00  
   1152x768      59.95  
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   720x480       59.94  
   640x480       59.94  
   **1328x998_60.00  60.00**  
Virtual-2 disconnected (normal left inverted right x axis y axis)
Virtual-3 disconnected (normal left inverted right x axis y axis)
Virtual-4 disconnected (normal left inverted right x axis y axis)

[s4ndm4n@s4ndm4n-standardpci440fxpiix1996 ~]$ sudo xrandr --output Virtual-1 --mode "1328x998_60.00"

After that, I have the resolution set to 1328 x 998.

Also, you don’t have to run xrandr after xrandr --newmode command I used that only to make sure which output is being used. By now you know it your HDMI-0.

1 Like

I am still getting the same error on addmode unfortunantly. I don’t know why.

$ sudo xrandr --newmode "1328x998_60.00"  110.08  1328 1408 1552 1776  998 999 1002 1033  -HSync +Vsync
[sudo] password for : 
$ sudo xrandr --addmode HDMI-0 "1328x998_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  39
  Current serial number in output stream:  40

So, little update, someone has tricked me into uninstalling lightdm, which as you may know, spells death for EndeavourOS. The install was not recoverable. I am looking at different arch distros that have matured alot. It’s a shame to leave Endeavour because it looks so good. I will still be back needing help in an hour or few if I encounter the exact same display resolution error on another Arch distribution.

UPDATE. I have added 1328x798 to Garuda linux, It does not work and black screens. Prolly cause GTX 660 does not support it. I will now try 900P. Hopefully Endeavor fixes Xrandr bugs specific to their OS later down the line.

There is no xrandr bugs specific to EndeavourOS. It is obvious your hardware doesn’t support the modes you are trying to implement.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.