Disney plus playback issue

Problem: Disney plus does not play video/audio black screen.

what I have done: I have enabled DRM on librewolf. I have also tried in firefox DRM was also enabled in firefox. I was able to get Netflix working in librewolf and firefox. also the reson I tried firefox was just in case librewolf was the problem.

If there is any information i am missing or need to add please let me know.

System Specs

Kernel: 6.0.5-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.26.2
Distro: EndeavourOS
Type: Desktop System: Dell product: OptiPlex 790 v: 01
Mobo: Dell model: 0HY9JP v: A02 serial: BIOS: Dell
v: A22 date: 07/03/2018
Info: quad core model: Intel Core i5-2500 bits: 64 type: MCP cache:
L2: 1024 KiB
Speed (MHz): avg: 3178 min/max: 1600/3700 cores: 1: 3342 2: 3396 3: 3438
4: 2539
Device-1: NVIDIA GK208B [GeForce GT 710] driver: nvidia v: 470.141.03
Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: nvidia
unloaded: modesetting gpu: nvidia resolution: 2560x1080~60Hz
OpenGL: renderer: NVIDIA GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel
Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel
Sound API: ALSA v: k6.0.5-arch1-1 running: yes
Sound Server-1: PipeWire v: 0.3.59 running: yes
Device-1: Intel 82579LM Gigabit Network driver: e1000e
IF: enp0s25 state: down mac: d4:be:d9:9d:1a:fb
Device-2: NetGear A6210 type: USB driver: mt76x2u
IF: wlan0 state: up mac: 10:da:43:17:a8:66
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb
Report: rfkill ID: hci0 state: up address: see --recommends
Local Storage: total: 2.98 TiB used: 8.1 GiB (0.3%)
ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB
ID-2: /dev/sdb vendor: Western Digital model: WDS100T2B0A-00SM50
size: 931.51 GiB
ID-3: /dev/sdc type: USB vendor: Western Digital model: WD Elements 10B8
size: 1.82 TiB
ID-4: /dev/sdd type: USB vendor: PNY model: USB 3.0 FD size: 28.9 GiB
ID-1: / size: 219 GiB used: 8.1 GiB (3.7%) fs: ext4 dev: /dev/sda1
Alert: No swap data was found.
System Temperatures: cpu: 43.0 C mobo: N/A gpu: nvidia temp: 41 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Processes: 201 Uptime: 2h 57m Memory: 11.65 GiB used: 3.77 GiB (32.3%)
Shell: Bash inxi: 3.3.22

In firefox you can install user agent switcher and select windows/firefox83 from the pull down menu then DisneyPlus will work.

Thanks for the tip. Disney + worked up until yesterday for me on Firefox Developer Edition and stopped today when it updated to 107. Adding user-agent-switcher and setting it to Windows/Firefox 83 worked perfectly. Again, thank you for the tip :slight_smile:

That got it working!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.