Disk partitions

Hi there,
I am not really sure if I should post it here or not. My computer has 1TB SSD disk and I started using dualboot few months ago.

My windows update is kinda broken. I tried to stop regular windows updates like this: how-to-delay-windows-10. But my gpedit could not launch so I tried also this gpedit fix.

Now I tried to reboot to Linux with restarting pc and I am back in windows. I check my bios and boot options and Endeavour is not there.
So I found disk partitions from Windows and this is it.


First part says in english: Alright (system area EFI).
Second part - Windows: Alright (Misleading, paging file, The state of the system on failure, basic data area)
Third part - should be EndeavourOS: Alright (primary area)
Last part: Alright (recovery area)

It looks like my Linux has disappeared. Any advice?

You might need to reinstall EnOS’ bootloader in order to be able to boot back into your system.

You could do this from the live session. I hope you have still your bootable EnOS usb.

Here is a guide on how to go about doing this:


Follow the instructions for the UEFI system.

If anything is unclear, don’t hesitate to ask on the forum


Thank you, I am on it

1 Like

This should be correct partition according to fdisk -l command, but I dont really know what am I doing wrong.

Please post the output of:

sudo parted -l

and tell which partition is your EnOS system partition.

I didnt know if there is a whitespace or not because there is linebreak in that tutorial and I used sudo still nothing. Here is the output


In the live session, open a terminal:

(copy-paste one command at a time)

1. sudo mount /dev/nvme0n1p5 /mnt 
2. sudo mount /dev/nvme0n1p1 /mnt/boot/efi
3. arch-chroot /mnt 
4. grub-install
5. grub-mkconfig -o /boot/grub/grub.cfg
6. exit


Well this worked, but this worked but this time windows disappeared :DD

Boot into your EnOS:

Edit /etc/default/grub and set GRUB_DISABLE_OS_PROBER to false.

Then run sudo grub-mkconfig -o /boot/grub/grub.cfg

It’s a PITA to convince a system to “dual-boot” with Windows and with “other OS”, in this case EndeavourOS Linux. What I do on my system is to press [ESC] soon after computer is turned on which gives me the UEFI blue menu thing from the computer’s manufacturer (Hewlett-Packard 10-year-old laptop), ie. before GRUB. There I could choose an EFI file to boot into something other than Windows. Some people don’t like it that way however, expect GRUB to appear right after power-on and offer an option to boot into Windows as well as into a penguin.

pebcak I learned something from you, thank you!

1 Like

It was already set to false

Check if os-prober is installed. If not install it and run:

sudo grub-mkconfig -o /boot/grub/grub.cfg

It was already installed. I tried to run sudo grub-mkconfig -o /boot/grub/grub.cfg again and it fixes problem itself.
Thank you so much friend :heart:

1 Like

You are welcome!
Glad you got it all up and running again!

:enos_flag: :handshake:t5:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.