Discover doesn't show any packages

Hi,

I just installed EOS-KDE on a second machine (I have EOS-Cinnamon on another one) but every time I launch Discover, it won’t show any packages. I can’t figure out what could be wrong.

Make sure you install packagekit-qt5

2 Likes

Thank you so much! Installing the said package took care of it. Now i can see all the apps/packages.

By the way, though it didn’t show any packages before, I had a firmware update from Dell through Discover. Clicking the update bottom apparently downloaded the file which flushed the bios upon reboot. That was smooth!

1 Like

Could share for a newby on here, what is the command and can i do it on Konsole. Pamac has spoiled me

To install packagekit-qt5?

sudo pacman -S packagekit-qt5
2 Likes

sudo pacman -S packagekit-qt5

Will work on any terminal, including Konsole.

4 Likes

Beat me to it :joy:

4 Likes

Thanks so much to all of you. I had not looked at Discover in some time because it was so slow. But I just checked it out and then downloaded quickly a bunch of apps.

2 Likes

Interesting. Should this be a dependency for discover?

It is an optional dependency. I think it should be optional because you can use discover in different ways. For example, some people only use discover to manage their flatpaks. Also, if you are using plasma, installing packagekit-qt5 will activate the built-in update notifier which some people might not prefer.

Got it. That makes sense then. I guess I just figured that without it, discover almost seems pointless since it cannot really do anything.

1 Like