Discord Update

Hi there everyone. I note that Discord in their wisdom decided to upgrade to 0.0.17 and when you try to open our latest version 0.0.16 we are given a couple of options to upgrade which means unless I’m on Debian based system or want to build it from scratch via a tar ball I can’t use the desktop app version of it (of course I can use the browser version). I can build it from the tarball however given it is in the repo’s how long does it normally take before it get upgraded? No rush, just a question hoping someone from EOS might be able to answer. Here is what you are currently greeted with when trying to open it now :slight_smile:

discord-upgrade-options

For best results, wait until the package is updated in the repos, do not update it yourself manually.

Difficult to say, probably a couple of days…

That’s really strange. What happens if you select “I’ll figure it out”?

It closes and quits out of that notification screen. I know I’ve tried it just now :stuck_out_tongue:

1 Like

Well, that sounds like a garbage application, but that’s none of my business…

image

6 Likes

Because the binary protocol isn’t just magically incompatible every time the version gets bumped, you can get away most of the time with adding

“SKIP_HOST_UPDATE”: true,

to the .config/discord/settings.json. A normal update of discord should come within the next few days which fixes the version incompatibility.

1 Like

As @DromundKaas mentioned, there are ways to circumvent this, but I found that can mess up things at times. I would recommend just waiting for the repo package to get updated. This usually happens within 24 hours. If you really cannot wait that long, there is always the option to use it in the browser, or to switch to the nightly version (Discord canary it’s called I think?).

Thanks for clarifying @TheRaOct , I have so far no experience as to how that changes the Discord usage, I only found and applied the workaround today.

you can do this if you are in rush to use it

https://wiki.archlinux.org/title/Discord#Discord_asks_for_an_update_not_yet_available_in_the_repository

Thanks everyone. I think I’ll just wait for the repo to update as this is my main workhorse and trying to avoid messing things up. Like I said I can always just use the browser version if I need assistance. I do circuit board repairs and talk to a lot of engineers and independent repair owners and that’s why I use discord.

Thank a bunch everyone for responding so quickly. :slight_smile:

1 Like

it just landed in the repo

1 Like

Not for my location. I’m still getting 0.0.16-1

Perhaps refreshing your mirrors to get more updated ones might help.

pacman -Ss discord
community/discord 0.0.17-1
    All-in-one voice and text chat for gamers that's free and secure.
1 Like

or running pacman -Sy to sync with your mirrors first :wink:

1 Like

For some reason took a little while but it finally appeared. I actually did all the above and it was still showing 0.0.16-1 on the Australian repo. Looks like it has finally caught up now though :slight_smile:

1 Like

I just installed “Discord Canary” :slight_smile:

I just now updated to 0.0.17-1, and can report that adding

“SKIP_HOST_UPDATE”: true,

worked well in the meantime, and an update later on brings you up to speed.