Discord stuck in "RTC Connecting" when joining a voice chat on Vivaldi browser

Hi I just switched to Endeavour, and I’m experiencing a problem where I am stuck in the “RTC Connecting” part of when joining a voice chat using Vivaldi.
Please let me know what I should post to help the issue.
I have tested that the app itself will connect to a voice chat normally.

P.S, I’m using Vivaldi because of this guide and not the actual app itself, the app sucks anyway.

Hi! Welcome to the forum :enos_flag:

The issue could be with Discord app. In that case, waiting for an update is the only option. Discord app is in electron and closed source so I don’t know if we can do anything.

The only times I personally have encountered this is when my internet connection is weak/ slow for the server region. US-East region works good for me. If you are the server admin try changing voice channel region.

Screenshare with audio? I achieved that with pipewire and discord app. It wasn’t perfect but worked. Followed a guide on reddit.

Ah no, the app itself works fine connecting, however I am using Vivaldi browser to connect to voice chat, it’s a chromium browser which is needed to screenshare audio.

Oh? Could you share that guide? I’d really love to follow that guide to actually screenshare audio on discord instead of on the browser.

Generic guide

1 Like

ooh thanks

1 Like

ah yeah, i forgot that i was using wayland seems like this doesnt work too well for me. thank you for the help though, it’s probably something to do with the firewall thats making me stuck at “RTC Connecting” on the browser. Ill try finding some solution

Just posting this, seems like even using Opera browser doesn’t fix the issue of being stuck at “RTC Connecting” still. Very strange behavior.
I’ve also disabled firewalld, so i have no idea whta to tackle next.

Make sure webrtc is not disabled in your settings.

1 Like

I LOVE YOU THANK YOU. This fixed it.

1 Like

Welcome to the forum @Emily
Glad you got a solution.

thank you thank you, this place seems nice. also quite a surprise nobody took “Emily” as one of the usernames lol

Happy it worked out for you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.