Discord stuck at gray screen after start

When I returned from vacation and started up discord, it just stucked at gray screen. I found on some forums you have to install libc++, so I installed it from AUR and doesn’t seem to worked.
When i run discord command in terminal this is the output:

Discord 0.0.28
Starting app.
Starting updater.
2023-08-08T14:43:12.691Z [Modules] Modules initializing
2023-08-08T14:43:12.691Z [Modules] Distribution: remote
2023-08-08T14:43:12.692Z [Modules] Host updates: enabled
2023-08-08T14:43:12.692Z [Modules] Module updates: enabled
2023-08-08T14:43:12.692Z [Modules] Module install path: /home/xap3x/.config/discord/0.0.28/modules
2023-08-08T14:43:12.692Z [Modules] Module installed file path: /home/xap3x/.config/discord/0.0.28/modules/installed.json
2023-08-08T14:43:12.692Z [Modules] Module download path: /home/xap3x/.config/discord/0.0.28/modules/pending
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
2023-08-08T14:43:12.845Z [Modules] No updates to install
2023-08-08T14:43:12.846Z [Modules] Checking for host updates.
2023-08-08T14:43:13.086Z [Modules] Host is up to date.
2023-08-08T14:43:13.087Z [Modules] Checking for module updates at https://discord.com/api/modules/stable/versions.json
2023-08-08T14:43:13.124Z [Modules] No module updates available.
Optional module ./ElectronTestRpc was not included.

I even tried Discord Canary but it does the same thing.
And tried to delete .config/discord but nothing happend.
This is what the gray screen looks like:

Some users reported that discord segfaulted when launched. Can you check the journals to see if that was the case for you as well?

My journals says only this when i start discord:

srp 08 18:03:18 xap3x-pc dbus-daemon[612]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service' requested by ':1.442' (uid=1000 pid=22037 comm="/usr/lib/electron25/electron /usr/lib>
srp 08 18:03:18 xap3x-pc dbus-daemon[612]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service not found.

To narrow down the issue you can try:

You could also try checking what strace says. (strace discord)
However the system calls are hard to understand

The flatpak version works fine, thanks!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.