Discord not recognizing individual windows on EndeavourOS

So basically I have no complaints with endeavour os but when I attend a meet or a discord call and need to present something it doesnt show the applications separately. Discord or any other video call app just doesn’t acknowledge the fact that I have other windows open. Here’s a example:


so I do have like vs code and stuff open in the taskbar but still it was not picked up. I am using a xfce desktop with chicago95 skin on it btw. Please help it would be appreciated.

Are you on Wayland by any chance?
I have the same issue on Wayland with OBS.
You could try X11 as alternative.

This is a hard limitation of wayland, as Tiravian said you can use X11 instead if this is a deal breaker for you.

By design no app is allowed to know anything about what any other app is doing under wayland.

If it can be resolved, it’d be on a compositor by compositor basis. If any compositors actually support this on wayland it’d most likely only be KDE, but i’m not really sure if it does or not.

Part of the idea behind pipewire was also to resolve these kinds of issues for wayland but i’m not sure if there is any proper implementation for this specific use case yet.

I cant abandon xfce man, I love my chicago95 setup. Guess this is my life now.

well, xfce is actually on X11, so this should be working for you.

Are you using pipewire?

Try this: https://askubuntu.com/a/1336046

You could also try alternative clients like lightcord,ripcord or webcord; or you could do as I do and use one of the discord electron packages from aur (I’m using discord_arch_electron) which uses native electron isntead of whatever discord comes packaged with.

I just checked by typing pipewire in the terminal. Seems like it’s broken as it gives out this in red:

[E][06362.638778] mod.protocol-native | [module-protocol-:  760 lock_socket()] server 0x61d17b3faee0: unable to lock lockfile '/run/user/1000/pipewire-0.lock': Resource temporarily unavailable (maybe another daemon is running)
[E][06362.639014] pw.conf      | [          conf.c:  584 load_module()] 0x61d17b3b2cb0: could not load mandatory module "libpipewire-module-protocol-native": Resource temporarily unavailable
[E][06362.640153] default      | [      pipewire.c:  105 main()] failed to create context: Resource temporarily unavailable

Try using Discord from a web browser and see if it has the same results.

Yes same effect, it only gives option to share entire screen.

What are the outputs of:

pacman -Q | grep -i xdg

and

pacman -Qi discord
C:\home\cdkw2> pacman -Q | grep -i xdg
xdg-dbus-proxy 0.1.5-1
xdg-desktop-portal 1.18.4-1
xdg-user-dirs 0.18-1
xdg-user-dirs-gtk 0.11-2
xdg-utils 1.2.1-1
C:\home\cdkw2> pacman -Qi discord
Name            : discord
Version         : 0.0.54-1
Description     : All-in-one voice and text chat for gamers
Architecture    : x86_64
URL             : https://discord.com
Licenses        : custom
Groups          : None
Provides        : None
Depends On      : libnotify  libxss  nspr  nss  gtk3
Optional Deps   : libpulse: Pulseaudio support [installed]
                  libappindicator-gtk3: Systray indicator support [installed]
                  xdg-utils: Open files [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 244.28 MiB
Packager        : T.J. Townsend <blakkheim@archlinux.org>
Build Date      : Tuesday 14 May 2024 03:25:27 AM
Install Date    : Sunday 19 May 2024 01:48:54 PM
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

It seems you have everything you need, so that means it’s probably settings related.

Rename the folder below, then reboot your device and try Discord again.

.local/state/wireplumber

Also, try renaming/deleting your Discord config folder while you’re at it. You’ll need to log in to your Discord account again.

Also, just in case, what is the output of:

pacman -Q | grep -i wire

Lastly, you can give this a shot:

C:\home\cdkw2> pacman -Q | grep -i wire
gst-plugin-pipewire 1:1.0.6-1
libpipewire 1:1.0.6-1
libwireplumber 0.5.2-2
pipewire 1:1.0.6-1
pipewire-alsa 1:1.0.6-1
pipewire-audio 1:1.0.6-1
pipewire-jack 1:1.0.6-1
pipewire-pulse 1:1.0.6-1
wireplumber 0.5.2-2
C:\home\cdkw2> 

Also can you please explain what you mean be rename the folder below? I am kind of a noob only been using linux for 3 months

It’s nothing special to Linux. Rename the folder. Change the name of the folder to something like “wireplumber-bak”, then restart your device.

thanks for telling man, I am just paranoid to accidentally doing something calestrophic

You mean “catastrophic”, right?

please excuse the spelling, I am not a native speaker sorry…

1 Like

well even after changing the name and then rebooting nothing has changed. I am still unable to present a specific application. Only my entire screen.

https://archlinux.org/packages/extra/x86_64/xwaylandvideobridge/

I guess I am gonna use the arch-electron build now

I’ll give this a shot why not