Disconnected internet crashes laptop X11 or Wayland

Dear all,
Thank you, every time the internet is disconnected the laptop crashes.
It freezes, reconnecting Ethernet cable or an established connection doesn’t show unless the device is switched off and on again.
I can’t even open a simple terminal, tried another kernel and makes no difference.
Thank you

Hello and welcome to :enos: forums.

Would you be able to post the URL after running the below commands?

Most recent system log: journalctl -b -0 | grep fail | eos-sendlog

2nd most recent system log: journalctl -b -1 | grep fail | eos-sendlog

Sorry 4 the late reply:

Thank you.

Dear s4ndm4n,
Thanks again, were anything significant perceived from the logs please? :+1::blush:

Sorry, I got distracted.

Can you post the output of inxi -Fzzc01?

:rofl::rofl::rofl: I know…
Thanks 4 being kind and having a sense of humour :pray:

Have you tried using the current kernel?

Thank you Ricklinux, i use the 6.6.30-2-LTS.
I did try 6.6.30-2 LTS fallback, which one would u suggest i try pls?
-6.8.9-archi 1-2
6.8.9-archi 1-2-fallback
6.8.9-zen 1-2 & fallback…?
Thank you

The current kernel.

:+1: okay, Will try that and see.
Thank you.

Nope, tried -6.8.9-archi 1-2, didn’t freeze but won’t launch any software - eg. browsers, vlc or any software.

Have you updated lately? 6.9.1-arch1-1 is out


This doesn’t make sense. :thinking:

When did you do your last system update?

Yes very interesting…when network is unplugged i can’t launch any software and system just freezes, quite like it is waiting for me to plug in internet and reboot else nothing will work.
(18/05/24 _Updated & i think this fixed it - even used the default LTS :+1::pray: thanks :blush:)

Dear S4ndm4n,
I run it at least 1-2 days…
yay, pacman and even flatpak update on terminal as usual.
Just updated again 18/5/24 and was able to launch software and device did not freeze without WAN. I think the update fixed it. :blush::+1:

Well i can only say there have been a number of firmware updates and also the kernel as well as many other packages. Have you also checked to make sure your UEFI Firmware (Bios) is up to date?

Haven’t done the latest bios update as sometimes it might mess up other programs. I tend to wait for a few months…will do it, now that you have suggested it. :+1::pray: