Disabling KDE compositor makes plasmashell stop working until killed

I’m on a recent install of EndeavourOS (artemis nova release) w/ KDE plasma (installed clean about 10 days ago), but I noticed disabling the compositor, to boost games performance, makes plasmashell stop working until the process is killed and restarted.

This never happened on my previous eOS installation from march so I was wondering if anything could be done to prevent it from happening or it’s a bug I should report somewhere

2070super, x11

Try the lts kernel if you’re using the latest. It could be a kernel issue?

may I ask what I should do to do that? I’m not experienced about it and I don’t wanna break something

To see if akm is installed

pacman -Q akm

If akm is not listed (error: package ‘akm’ was not found) then install akm

sudo pacman -S akm

In a terminal window, run akm or launch akm from your apps menu

then check both “core/linux-lts” and “core/linux-lts-headers”

Click “Execute”

Reboot then use the up and down arrow keys to select the lts kernel.

To verify, in a terminal window

uname -a

The lts kernel should be listed


I did as you said, but after rebooting in the grub I still only have normal eOS and eOS with fallback intramfs

Is it elsewhere and I misunderstood where to select it?


Depending how you have grub setup you will may need to change it so that lts boots. If you have it hidden or a zero time out, you may not get the option.

Also if you havne’t yut you will need to update grub for grub to add it to be chosen. If you don’t know how to do that, it is also available in the wiki.

I got the lts kernel to show in the list and am currently logged from it, but the problem persists.
Process plasmashell still becomes unresponsive until killed

edit: I also noticed plasmashell tends to go up quite a bit in memory usage while it’s in this broken state