Disable XFCE login screen at startup

Hello again,
at the moment i use XFCE but the login at startup isn’t mine. How can i disable it? I saw that Plasma doesn’t use a login screen, so i hope it is possible to switch this off at XFCE?

Thank you and have a nice sunday.
Greetings,
Endlich.

Can you better explain what you are trying to do?

You want to login automatically, you want a TTY instead of a display manager or something else?

I ask because from my perspective plasma does use a login screen so maybe I am not understanding what you are referring to.

xfce uses lightdm and plasma uses sddm: what is yours Endlich

Do you mean there is another user at login?

Thanks for your posts. :slightly_smiling_face:

I used KDE Plasma once and for a time. And i saw that there is no login required. You boot the computer, let it load all what is necessary and then you are on the desktop. So i want this for XFCE, too.
I removed plasma and installed xfce, so which one sddm or lightdm i don’t know. But i guess lightdm, because it’s xfce right?

No there is no other user, it’s just that i don’t want to login at every startup. How to disable the lockscreen after inactivity i already found out.

By the way: … How do i replace the upper desktop bar from the top to the bottom?

Thank you.

1 Like

you started from which base or iso

I started from the latest iso download from endeavouros.com. But i switched after that from KDE Plasma to XFCE4. I installed the system from an USB-Stick and i chose KDE Plasma as DE in the installation routine.

you did this

1 Like

exactly.

Are you absolutely sure?

OK, you want to autologin.

Have you been through this:
https://wiki.archlinux.org/index.php/LightDM#Enabling_autologin

3 Likes

Yes, with KDE Plasma it worked fine and without any problems.

I will have a look at the guide from you, @dalto Thank you.

2 Likes

if you do change from sddm to lightdm, you will need to configure it again for autologin, you may already in the group

  • you can check with:
groups | grep autologin

(as normal user)

if yes you need only to configure /etc/lightdm/lightdm.conf

[Seat:*]
autologin-user=username