Disable "Hibernate" and "Save Session" in Plasma Application Launcher

A recent update to Plasma 5.19.5 caused two new options to show up in the Leave menu of the Application Launcher: “Save Session” and “Hibernate”.

I have previously disabled hibernation (since this is a desktop computer) by adding

AllowHibernation=no
AllowHybridSleep=no
AllowSuspendThenHibernate=no

to /etc/systemd/sleep.conf

However, the latest Plasma update does not seem to respect this setting. The “Hibernate” option is still in the menu, however, it does nothing (because hibernation is disabled). The “Save Session” option also seems to do nothing, apart from cluttering the menu.

After searching for about an hour in the System Settings, I couldn’t find the option to remove “Hibernate” and “Save Session” from the menu. It’s probably somewhere there, staring at me, but I just can’t find it. So if anyone knows how to disable it, please let me know.

4 Likes

Have you tried another menu say Excalibur menu?

2 Likes

No, I quite like the default menu.

1 Like

Was just trying to see if it was just that menu that was bugged.

My bet would be yes. If I remember correctly, from a recent “This week in KDE Plasma” there was some bug fix that introduced this “Save Session” option.

1 Like

It might be related to this:

Note especially comments number 3 and 4, from KDE dev Nate Graham.

I’d wait a bit before trying to edit system files; I imagine there will be some changes coming.

3 Likes

You were right @tardy, updating to Plasma 5.20 fixed the problem. :+1:

4 Likes