Disable C-States?

Hi there,

I’m running a AMD Ryzen 7 1800X Eight-Core Processor

I get the following in the logs for each processor core

[Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)

BIOS is up to date

Should I just disable C-States in BIOS or is there something better I could do?

Many thanks

Yes you could do that. Make sure you have latest AMD ucode and Bios is up to date and microcode is applied.

check here & you should see the same error messages

 dmesg | grep microcode

I believe this is a bug with some 1st generation Ryzen CPUs. Not sure though. Please google it.

This just gives the current patch level, no errors for each core

microcode: CPU0: patch_level=0x08001138

There’s no sign in the logs of microcode being updated at boot. Maybe that’s because there’s no newer version than that provided by the BIOS which is up to date?

Sorry, I’m a bit confused by how this is supposed to work despite plenty of googling!

Thanks for the thoughts

I guess it just shows that the micro code is implemented. You can just disable c states in Bios if you don’t want to see the error messages otherwise i would just ignore it if there is no issue.