DirectX game not working after update

I updated my system and unfortunately my UT2004 game no longer works. It throws me a ‘Please install DirectX 8.1b or later’ error. It is the second time it broke after an update, but last time I could fix it by using an earlier Proton-GE version. The game has the same problem through Steam, Heroic games launcher and Lutris. I have an Nvidia RTX3070 which might be relevant information.

How can I get it back up and running?

What did you update - the system, Steam, or both?

Both, in that order.

The latest posts are from 2 years ago (, but some users mention switching from D3D to OpenGL as a fix (for other problems).

I did try that but no luck. The problem is not with the game, it has worked flawlessly for months. It is the update that broke something else in the system but I don’t know what.

I’m still looking for a solution. It seems that it is a Vulkan driver issue as running steam from the console shows me this error:

vkEnumeratePhysicalDevices failed, unable to init and enumerate GPUs with Vulkan
BInit - Unable to initialize Vulkan!

any Ideas how to solve this?

  • edit
    I’m getting closer: I installed the lib32-nvidia-utils and lib32-vulkan-mesa-layers packages which solved the Vulkan initialization problem. The game sort of launches: It doesn’t start but gives me a CDkey error. Heroicgameslauncher is also still not loading.