Different errors in Online Installer and Community editions

Hello everyone.

I was trying to install EndeavourOS for the first time today. My SSD already has Windows 11 installed and there are ~250GB Unallocated.

When installing, I choose the free space in my SSD, but I get different errors. The first one is

With the Online installer, I set up the languages, select PLASMA KDE as DE, select the partition and install but I get an error with Python and Windows boot https://termbin.com/uczz

With the community edition installer, after choosing the Sway version, I get the error
Installation failed - package manager error: The package manager could not make changes to the installed system. The command

returned error code 1.

I already tried searching for a fix, but the only thing I found was to remove pcurses. I’m using the last ISO available (I think) since I downloaded it this morning.

I’m installing via USB choosing the NVIDIA driver “version” (but I also tried the standard one). If it can help, I’ve a MSI Z-690, 32GB of DDR5 RAM, a GIGABYTE RTX 3060 and and Intel i5-12600K.

The community editions issues are because of recent package change. That is being worked on.

Your other issue is because of this:

 [Errno 30] Read-only file system: '/tmp/calamares-root-k_4nfc9i/efi/EFI/Microsoft' 

Your EFI partition is read-only. This is typically caused by not disabling fast-startup in Windows settings or by your EFI partition having some corruption that needs repair.

1 Like

Thank you very much, let my try again


there is a package change upstream for ttf-nerd-fonts-symbols-2048-em used by community editions… you can untag this from packages screen or wait till there is a fix for it…

Welcome to the EndeavourOS forum. I hope you enjoy your time here.


You are right, now I only have the bootloader error even if I remount everything in wr. I’ll investigate further

I just tried this in vm and i also can’t get it to install.

Edit: I don’t see the font’s and i can’t seem to get it to work for me. I’ve tried numerous times on vm. I’m not sure what the issue is?


you should consider using a new ESP instead of the one from windows…
You have that option on the bottom of the partition screen to set using “new”

It is in the section for the CE, not the general fonts section.

Okay. Sorry i misunderstood. I found it now and try again.

Edit: For a minute there i thought it was already removed from the packages.

1 Like

I can confirm that it is working. Installed in vm on Bios.


Edit: Installed Sway on vm in Uefi. Also working after removing fonts package.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.