DietPi on RPi Zero does not boot | dd wrong usage?

Hello dear Community, i hope this is the right Forum as I just need some general advice for my Pi.

It was running PiHole on RaspberryOS for a time. Now I want to run it on DietPi because it needs lesser resources.

Steps I did:

  1. Downloaded the DietPi_RPi-ARMv6-Bookworm.img from the DietPi Website.

  2. Copied the .img to not formatted sdCard via sudo dd if=DietPi_RPi-ARMv6-Bookworm.img of=/dev/sda bs=8M status=progress
    → the partitions are correctly shown in gparted

  3. Insert Card in Pi and Plug Power in. (Pi is connected to LAN with LAN to mUSB Adapter - everything working normal before!)

→ As the Pi does not show up in my Router overview, it seems it does not boot the OS.

Is there anything I missed?

Thank you very much.

By all means, there may be some users on EnOS’ Forum using DietPi who perhaps could help you out.

With that said, DietPi seems to have its own support venue:

You are absolutely right.

I posted here because im already active in the endeavourOS forum and I thought I messed something up with the dd command.

I already flashed DietPi with balena-etcher on another device without problems.
But at the moment balena-etcher does not work because of some electron issues.

So I tried dd as it’s very cool and quick. :wink:

Your dd command seems alright.

Do you still have access to your RaspberryOS? If so you could use rpi-imager to flash your card

rpi-imager is in AUR as well:

Also gnome-disk-utility could write an .img file to a device.

1 Like

No but I’m on EOS. :smiley:

I’ll try the disk utility, thank you very much!


Apparently it’s installed, but i cant find it. :confused:

I also tried the rpi-imager but it does not work either.

Seems i just have to wait until balena-etcher is working again.

1 Like