Diablo IV - "GPU Not Supported"

Every time I try to launch Diablo IV from Battle.net it gives me the “GPU Not Supported” window.

And I truly do not understand. This Battle.net and Diablo IV installation is without Lutris or Bottles.

Even when i installed the VKD3D package. No success.

Any help would be appreciated.

Please and Thank you.

Screenshot from 2023-07-03 01-37-04

Screenshot from 2023-07-03 01-43-07

What version of dxvk and vkd3d do you have installed and are you running the native Lutris package or the Flatpak version?

Since you are linking to the Arch package I’m assuming you have the normal Lutris version installed. I’m using the Flatpak version for Lutris and I have dxvk v2.2 and vkd3d v2.0 installed try seeing if you get install those same versions using ProtonUp, you can install it as a Flatpak or from the AUR.

I got this warning too, but the game worked in beta after clicking okay. Install with Lutris. For me when something really doesn’t want to work I use a diffrent driver(radv or amdvlk)

you can switch drivers, if both is installed with AMD_VULKAN_ICD=RADV

What DXVK and VKD3D-PROTON versions are you using? That will probably be the key factor in your problem.

Last time I ran Battle.net on Linux was through Steam; Diablo II: Resurrected ran pretty well. I would think that Diablo IV should run just as well. System specs for the (2) games are very similar.

I have installed

aur/vkd3d-proton-bin 2.9-1 (+11 1.00) (Installed)

aur/dxvk-bin 2.2-1 (+215 2.38) (Installed)

Also, this is me trying to run the game with no Bottles or Lutris. So like manually or just with Wine. No Flatpak either.

I do not understand how the software or application is not recognizing the Dx12 files or that the GPU does indeed support Dx12

No idea then, looks good.
Also I have no idea how exactly are you running the game via terminal. What commands do you enter?

What Wine version are you using actually?

It could very possibly be that the upstream Wine doesn’t have the needed fix for D4.

Try to use this Wine version: https://github.com/GloriousEggroll/wine-ge-custom/releases/tag/GE-Proton8-9

I have it running here using Lutris without any issues. Why not just make it easier on yourself and use Lutris or Bottles?

1 Like