Desktop centering

Good evening, I recently installed this operating system coming from Windows 10, I have a problem is that I can’t hit the screen, the sides come out with the 1920x1080 resolution while if I lower the resolution, I centered but I lose brightness of image, I wanted to know if There is a system for tightening the screen, with Windows I used the integrated Intel HD4600 video card software and tightened the desktop. Thank you.

Could you post your hardware to start with. Please post the link.

inxi -Faz | eos-sendlog

So it is an older Intel graphics. What resolution are your monitors? What is the default or native resolution?

Edit: Can you check if xf86-video-intel is installed ?

pacman -Qi xf86-video-intel

Edit2: If it is installed i would try removing the Intel driver and reboot so it will use the kernel module instead.

sudo pacman -R xf86-video-intel

1 Like

Hi, I tried to type the command you gave on the terminal but tells me that the package was not found

If the package isn’t installed i guess you could try it by installing it and reboot and see if you can set the resolution and if there is any difference. I don’t know what the native resoltion of your monitors are? Are they 1920x1080 or something else?

sudo pacman -S xf86-video-intel

Now I try, the monitor is 19201080p, however I installed in Dual Boot Windows 11 and through the Intel HD Graphics software I managed to hit the monitor in 19201080 in two minutes, I don’t understand why it is not also available in this distribution

Do you mean you want to set the correct resolution for the monitor so it fills it?

Intel only provides those tools for Windows only. Also, keep in mind Windows and Linux are two different platforms. So, everything you have in Windows might not be available in Linux or you might find something far better.

Is your problem solved?

Tested, nothing to do in 1920*1080 part of the screen comes out of the monitor, if there was a Linux software capable of narrowing the screen manually similar to that of default Intel HD that appears on Windows would be the final solution. One last thing, as I avoid at each start the Richesta of authentication for the internal hard disks that I have installed, sorry but I am trying to learn and it is not easy coming from Windows.

It’s not easy at all but everyone has to start somewhere. Windows is all point-and-click. Linux gives more power to the user by letting them control everything.

Did you try setting the resolution in KDE settings?

Another thing I noticed.

Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 7
    dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux

Don’t know why you’re using KDE Plasma with LightDM. Because KDE Plasma has its own display manager SDDM

As @s4ndm4n asks why are you using lightdm? KDE Plasma uses SDDM. You would go into settings, display and monitor to set resolution.

Edit: Are you using more than one monitor?

I don’t understand this? What do you mean?

Now I try to see, sorry but for a few days I have installed this system and I don’t have much manual skills, as far as the hard disks I mean that I installed two SSDs for the two operating systems and two other hard disks for data and on this system Operating every time I start the system asks me for the password for the automatic assembly, I asked if it was possible to avoid that every time I start the system, insert the password to open the folders.

I am using two monitors, as far as LIGHTDM is concerned, now I try to see if I can change mode, looking for the command of course

How did you end up with lightdm?

I have no idea, how do I go to SDDM?

Did you install KDE originally?


sudo pacman -S sddm
systemctl enable --now sddm

Yes, I have actually installed several aspects also KDE

When I try to start from the terminal the command you gave me replies "Failed to enable unit: file /etc/shystemd/display-manager.Service Almedy exys and is a symlink to/usr/lib/system/system/lightdm .service. "

You may have to stop lightdm first

sudo systemctl disable lightdm
sudo systemctl enable --now sddm

Hopefully i got this right. :wink: