Desktop Apps Lagging Upon Opening/Closing



Apologies if this is not the correct place for this. @ a moderator please move it to the correct place if this isn’t it. Thank you.

I recently switched from Arc Darkest Solarized + Material Suru Icons to Arc Darkest Nord Frost + Papirus Dark icons and back. Upon doing this, and rebooting, I’m noticing that my apps - both GTK and Qt - are lagging out for a few seconds when starting them up and closing them.

I looked online and found that strace -r (app) may help, so here’s what I could catch of strace -r caja: (this is not the full log, the full thing did not show in MATE Terminal due to being too long). Also I did not notice anything abnormal in htop.

As for the system, is it a 81X2 IdeaPad Flex 5 14ARE05 with kernel 5.11.11-arch1-1. CPU is AMD Ryzen 7 4700U with Radeon Graphics (8) @ 2.000GHz. GPU is AMD ATI 04:00.0 Renoir. I am running MATE 1.24.1.

Please let me know if there is any other information needed and I will give it. Thank you.

Looks like your theme may be broken; does it look like you expect it to? (qt apps might be set to use the GTK theme, via QT_QPA_PLATFORMTHEME=gtk2).

what if you change it back? does it help?

I changed it to several different themes - Arc Dark, Adapta Nokto, Adwaita, etc… They all look how I expect them to, but all of them have this issue (which particularly for Adwaita is weird).

This happened only upon installation of the Arc Darkest Nord Frost theme - should I try deleting the theme and seeing if that helps any?

Hmm, very interesting. perhaps try changing the theme and icon to how it was before the issue. Perhaps this is a coincidence, not related to the theme. If that doesn’t help (after logging out and back in) maybe check journalctl | tail -n 40 or similar.

That’s what i would do.

The setup was Arc Darkest Solarized + Material Solarized Suru icons which I had switched back to.

As for journalctl | tail -n 40 I ran this as my regular user (joseph). It is worth noting that I did listen to a song via Quod Libet so that may have affected it, if it does then I’ll run the command again after just opening/closing things -

I am still considering the idea of deleting the Arc Darkest Nord Frost theme. If I should do this please lmk.

Looks normal, maybe 40 is not enough… does journalctl | grep -i gtk return anything odd?

instead of deleting the theme, I suggest that you move it somewhere else, like ~/, where you can copy it back quickly, that way GTK won’t pick it up.

Tried moving the theme to /home/joseph/Downloads, did not change anything.

As for journalctl | grep -i gtk, I put a pastebin of the result here -

When you moved it, then applied another theme, it took no effect? Perhaps reboot, but I suspect the issue may then be unrelated.

Those logs seem to be normal, I get something similar…

A reboot fixed the issue, thank you very much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.