Dependency failed for /home

Hi EndeavourOS team , i been new to arch and this is for the first time I have faced such an encounter, i tried to do the steps suggested but that didn’t work for me , my system configurations are i7 , with 16gb ram and nivida 1660 super , i have 4 operating systems install i.e, ubuntu, Windows 10 EndeavourOS and Manjari , Windows 10 and Ubuntu have been installed on a SSD while Manjaro and EndeavourOS has been installed on WD Elements (external hard drive)

Need urgent help

Hello, welcome to :enos: forums.
It seems you have mirror issues and need to update your mirror. try updating your mirrors first using reflector and try again.
https://wiki.archlinux.org/title/Reflector

1 Like

Err…that doesn’t look a mirror issue. The problem is they are trying to run pacman from an emergency maintenance shell where there is likely no network.

@anukulsharma, after you get into that shell, can you share the contects of /etc/fstab and the output of lsblk -o name,type,fstype,size,uuid

Depending on what /home is, we may need to run fsck on it.

2 Likes

Yes, you’re right, arch-chroot command wasn’t found. I should’ve looked closer

hi @sradjoker thanks for your quick response, i want to mention that i have some very important data in my EndeavourOS and i don’t want to lose it , and can i install reflector from this screen only or do I need to boot into a Live usb session? And if you could brief me how to safely update mirrors using reflector , since i don’t know much

I’m wrong, follow @dalto 's instructions

Hey @dalto

Idk how to copy paste this , so I’m attaching an image and to /etc/fstab it said permission denied

Sdb13 is my home and root of endeavourOS
Sdb12 is my efi
Sdb11 is linuxswap

That is a file. Type cat /etc/fstab

1 Like

Why not use a live session >> Internet connection >> login to forum >> posting output as text etc. etc.

In this case, the pictures are fine and that would require additional steps of explanation.

We want text when it is practical. If you are in a situation where it is less practical there is no reason to jump through hoops for it.

2 Likes

Here’s the output to cat /etc/fstab

It looks like your /home is on sdb5.

Try running fsck on sdb5 and see what the results are.

I would reboot clean before you do that. You did some strange chroot stuff there.

2 Likes

No @dalto my /home is sdb 13 I know that and sdb5 is /home for Manjaro , you want me to try the same commands ?

For now I’m trying fsck /dev/sdb13

Is that okay??

According to your /etc/fstab it is not. What is the result of cat /etc/os-release

It shouldn’t hurt anything, but it won’t help either.

Okay lemme try it fsck also

So sdb5 is definitely your /home. Is it possible you tried to mount your manjaro /home in EOS and that is causing this problem?

1 Like

No i tried to use manjaro today and it was working fine and in the manjaro terminal , i had tried all the earlier commands that you have seen in shell

I had put these commands in xfce terminal of manjaro

Sudo su
Mount /dev/sdb13 /mnt


… Update grub

Well, your /etc/fstab clearly identifies sdb5 as /home. If that is wrong. You should comment that line out /etc/fstab

That does nothing except updates Manjaro’s grub. I am little worried that all these random commands you are typing may have broken something further.

2 Likes

No but the commands didn’t get executed, the output was the same as you saw in shell , nothing got installed and updated :frowning:

Is there anyway to get started for once ? So that i can backup my data ?

This is probably easily fixable.

Did you try running fsck on sdb5 yet?