Dell XPS 13 no keyboard after resume from suspend

I’ve been using my Dell XPS 13 9370 without problems with EndeavourOS for some time; I’ve started to have problems when it resumes from suspend (to RAM, not hibernation): the suspend completes successfully, but when it resumes, I cannot use the keyboard, which is unresponsive. I see the login screen, I can use the touchpad but not the keyboard.

Anyone else experienced such a problem?

I have the problem both with lts and non lts.
Both on battery and on AC.

Does this occur on the lts kernel as well?

Yes, see above my original post.

On a side note: it does not happen in Ubuntu 23.10 (kernel 6.5.0), so it’s not an hardware problem

Have you tried using the following kernel parameters?

i8042.nomux=1 i8042.reset


I disagree with this because some hardware has to wake back up or restart when resuming.

It turns out to be a kernel bug.

Hint: Downgrade your kernel to 6.6.12 and stay with that version until the issue is fixed.

1 Like

Thanks, I’ll try that ASAP

I have the same laptop. Just downgraded the kernel to 6.6.10-arch1-1 and the issue is solved by that. Thanks!

You can still use 6.6.12 if you like. All versions higher than 6.6.12 are affected.

I confirm that downgrading to 6.6.12 fixes the problem!
Thank you @anthony93

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.