Default Wallpaper Deleted On Its Own

So I had a Galileo Install A few Days Ago with KDE as my preferred DE . I set it up with wallpapers and everything was good , until today when I tried switching back to Endeavour Default theme from Apperance Settings in KDE.

The Wallpaper was black , or blank must I say , tried scouring all desktop and wallpaper settings couldn’t find it .

Right Now after a fresh install it is present there .
Not a usability issue but I would like to know what could have caused it to delete on its own regarding this strange behaviour. A kde bug ? , I dunno.

The wallpaper is installed as part of a package. If you literally mean the wallpaper is no longer there than that would most likely mean that the package was removed.

If the wallpaper simply reset. It could be some KDE issue but it should have been possible to reapply it.

If it happens again, come and ask about it before reinstalling and we can help you troubleshoot it.

There’s another recent thread describing a similar issue. I believe it is an issue with KDE or SDDM, but I haven’t had time to chase down other bug reports, etc to verify. Thread here:

The SDDM wallpaper is completely different.

@Hitman_Agent47 can you confirm which wallpaper you are referring to? The one on the login screen or the one used on the desktop?

Desktop screen , home desktop screen wallpaper sir .

1 Like

The default wallpaper is in folder /usr/share/endeavouros/backgrounds.
Is that folder empty?

They already reinstalled :slight_smile:

However, even if that was still present, if the theme files were missing it could cause a similar problem.

It happened while the location was , urs/share/Wallpapers/EndeavourOS/contentimages

While it was still a fresh install this folder had the wallpaper , but after a few days and after I used my desktop as usual , today before reinstalling the folder was empty.

AFAIK that has never been the official folder for EndeavourOS wallpapers.
Are you using some other (non-EndeavourOS) packages as wallpapers?

That is part of eos-settings-plasma. It is where plasma looks for the wallpaper.

The folder is


I dunno , Galileo iso latest build , fresh install kde , that is all I know . Comes with a default Galileo wallpaper.

Yes , this only , forgot to put the slash.

Anything that can delete the theme files ?

Uninstalling the package would be the most common way.

Those files require root access to delete.

I dunno then , seems like a kde bug or smthng like dat.

Well this also happened with me exactly , except the wallpaper was for desktop not SDDM

I can’t help but think my issue is related. Following a fresh install, with the correct default wallpaper and theme active and showing, I went to System Settings, clicked the “Apply Plasma Settings” in the SDDM screen (so that SDDM would pick up the theme and wallpaper). I also clicked the “Change Background” for the SDDM login screen (again, so it would be consistent across my desktop) and chose the default wallpaper, which was available.

When I applied the changes and went back to my desktop, the default wallpaper was gone. I found it had been deleted from the default path referenced above (/usr/share/wallpapers/EndeavourOS/contents/images). I had to reinstall from the EnOS git/repo. Thus, my issue did affect the default wallpaper. I may just have triggered it in a different way. For the record, I had not deleted any packages or themes from the base install.

Maybe this will help. It certainly could be unrelated and irrelevant. Just a data point, I suppose …

This definitely seems related . I believe it to be a KDE bug .

Any further things that could cause this ? or should I close this issue as a KDE bug.