Default hybrid graphics on EndeavourOS

I’m using Linux for 4 years, I switched to EndeavourOS one month ago.
usually, when I install Linux I install Nvidia drivers and optimus-manager (when I was using X11) or envycontrol with Wayland.

but after installing endeavour I found the Nvidia card running in a hybrid mode without installing anything.

I want to know how this happen without using envycontrol or any Nvidia optimus method.

will installing envycontrol help with something ?, I think my laptop using more power when using the battery.

It would be useful to show the hardware output. Post the url.

inxi -Faz | eos-sendlog

I mean which method of these do EndeavourOS use by default

Your laptop is rendering on amdgpu.

API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.0.8-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    renoir LLVM 17.0.6 DRM 3.54 6.6.32-1-lts) device-ID: 1002:1636
    memory: 500 MiB unified: no display-ID: :1.0

You installed eos and it has installed the nvidia drivers but you still need a method to switch to the nvidia card. I’m not sure what settings the Bios has if it can set hybrid, integrated or dedicated. I’m not sure why you are you are saying this?

in the past Linux distros I used, the Nivida card was not running unless I used Nvidia optimus like envycontrol or Optimus manager, but now I found it running without using them, what I’m asking about: should I install envycontrol ?

The nvidia drivers are installed when you use the nvidia option on the live ISO to install. They are indeed installed and loaded but your hybrid system is running on the integrated graphics (amdgpu) You still need a method if you want to switch to render on the nvidia gpu. You can try either method if you used them before on this hardware then they should work and obviously you have experience or knowledge of how they work.


sorry for bothering you

I noticed the Nvidia GPU starts working when using Graphics programs, does that mean I’m using hybrid mode now?

Your laptop may have that option. Have you checked your bios settings? Does it have that option to set hybrid, integrated or dedicated. I’m not sure how you know it’s using the nvidia card when using graphics programs? I’m not familiar with your hardware.

I’m using Lenovo Legion 5, the default mode in the BIOS is hybrid and it is enabled (I should use Nvidia optimus on linux to use it).
I know it using nvidia-smi and nvtop

I see so because it has hybrid mode that is why it is automatically using nvidia when called to. I guess you could try either package then? maybe you have a preference. :thinking:

I’ve installed envycontrol, and there is no difference in the hybrid mode, but when I’m using the laptop without an external monitor I switched to integrated mode and the battery now works double the time.
sorry for these newbie questions, but I had trouble installing Endeavour (after 2 days of installing it, the kernel panic, and I reinstalled everything) and don’t want to experience this again.

Thanks for your help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.