Default File Search in Dolphin not working


Is there a solution to fix the search in dolphin? I tried like everything, but I can’t get it to work.
Currently I have some Filenames like glass.png and glass_s.png, but when I search in dolphin for glass in the folder where the Files are located nothing is found.

It seems a bit random, since yesterday it worked at least partially, but today nothing is found if searching within the folder. But when searching all Folders, it finds the files though.

System:    Host: name-arch Kernel: 5.12.8-arch1-1 x86_64 bits: 64 Desktop: KDE Plasma 5.21.5 Distro: EndeavourOS 
Machine:   Type: Desktop System: Gigabyte product: AX370-Gaming 3 v: N/A serial: <superuser required> 
           Mobo: Gigabyte model: AX370-Gaming 3-CF v: x.x serial: <superuser required> UEFI: American Megatrends v: F50a 
           date: 11/27/2019 
CPU:       Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP cache: L2: 3 MiB 
           Speed: 1372 MHz min/max: 1550/3400 MHz Core speeds (MHz): 1: 1372 2: 1320 3: 1727 4: 1330 5: 1327 6: 1386 7: 2373 
           8: 1342 9: 2409 10: 1364 11: 1310 12: 1362 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] driver: amdgpu 
           v: kernel 
           Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati unloaded: fbdev,modesetting,radeon,vesa 
           resolution: 3440x1440 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Device-3: Kingston HyperX Cloud Flight Wireless Headset type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server-1: ALSA v: k5.12.8-arch1-1 running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: e0:d5:5e:4f:51:bd 
Drives:    Local Storage: total: 2.27 TiB used: 249.67 GiB (10.7%) 
           ID-1: /dev/nvme0n1 vendor: Crucial model: CT500P1SSD8 size: 465.76 GiB 
           ID-2: /dev/sda vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB 
Partition: ID-1: / size: 97.87 GiB used: 7.46 GiB (7.6%) fs: ext4 dev: /dev/nvme0n1p3 
           ID-2: /boot/efi size: 1022 MiB used: 280 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p4 
           ID-3: /home size: 348.12 GiB used: 17.74 GiB (5.1%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-4: /var size: 9.75 GiB used: 2.39 GiB (24.5%) fs: ext4 dev: /dev/nvme0n1p1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 37.8 C mobo: N/A gpu: amdgpu temp: 52.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:      Processes: 318 Uptime: 55m Memory: 31.37 GiB used: 4.04 GiB (12.9%) Shell: Bash inxi: 3.3.03

Is baloo running properly?

balooctl status

Looks to be okay.

Baloo File Indexer is running
Indexer state: Idle
Total files indexed: 10.087
Files waiting for content indexing: 0
Files failed to index: 0
Current size of index is 8,31 MiB

You might try rebuilding your index. Your system performance will suffer a bit while it rebuilds.

If you want to try that:

balooctl purge

Thank you. Rebuilding the Index worked and now after a reboot the search is working again.

Just to be sure, is the reboot needed?

Probably not but tech support recommends it. :rofl:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.