Default colors in xfce-terminal not being readable at all

Does anyone knows how to get rid of this purple filter everywhere in xfce-terminal?
The colors are not what they supposed to look. They look fine in other terminal emulators, it is just xfce that is like that and based on the color which is purple and is the theme of EOS I suspect it is not an original setting for it.

Can you clarify what you mean by “purple filter?”

If it’s the background color, you can easily change it in the terminal settings.


This is how it looks for me

Here’s the thing. Starship selects the colors based on the terminal colors variables predefined by your terminal. In Starship’s code, the developer might have set the cursor color with a variable, say, “purple”, for instance. It is up to the terminal emulator itself to decide what actual color codes to assign to each of those variables.

To view xfce4-terminal’s current color palette, run neofetch on your xfce4-terminal. For example, on my system:

1 Like

Here is what I mean by the terminal emulator defining its color variables. On my terminal emulator (alacritty), I have edited my terminal’s config file to set the color variables with the following color codes:

You need to figure out how to do the same for your terminal.

I just installed xfce4-terminal to check out its settings.

You can change all those colors under the palette section.

1 Like

Look at the colors i posted above. it is clearly not normal. The weird thing is that i have not touched the config. It was like this from the moment I installed EOS. Clearly it is a EOS config thing. I just want to look normal. I was using alacritty too and the default configs on it are very sensible. Unfortunately it has other problems tho.

Standard Cassini install.


Yeah I see that, but i am not sure what should I map. I just want it to colors look as they should as normal.

If you want Starship on xfce4-terminal to look like Starship on terminal emulator X, you need to get all the color codes from terminal X’s color palette, and then change xfce4-terminal’s color palette to have the exact same color codes.

Like I said earlier, terminal applications usually don’t hard code the colors into the application itself. The application itself only expresses its theming in terms of variables like black, purple, red, … etc. It is up to the terminal to decide which color code to assign to each variable.

But why? :laughing:

here the color palette from config file. what should i change in that?


You mean the color palette for the Starship look you want? Or the current color palette for xfce4-terminal?

No , the starship was an example. nothing looks normal. Which i do a ls --color the colors are wrong and make the text unreadable. it just want every color just look like what its name says it should be. It is not a custom thing for me. I just want it to get rid of junk here.

… I already explained why this is the case.

I have also explained this…

You can change the colors by selecting different colors in the palette section…

(In case you are still unclear, this screenshot shows the interface for xfce4-terminal-settings gui)

Click on each color square under the palette section and change it to the color code you want.
From left to right, each rectangle represents the color code for: black, red, green, yellow, blue, magenta, cyan, and white. The top row is for normal colors. The bottom row is for bright colors.

If you look at the screenshot of the palette, you can see that the normal green (top row, third rectangle) is not green at all. This is probably why the starship colors on xfce4-terminal doesn’t match the colors on other terminal emulators.


This one is a bit different, but still shows green as purple for example

This is the default on Cassini with xfce4 terminal. :man_shrugging:

Lol… Cmon man… If you look at the screenshot in @ricklinux 's reply

Look (the first row, third rectangle is the color code for “green”):

You can clearly see WHY the terminal shows green as purple—because it’s been configured that way.

The normal “green” (third rectangle on the first row) has been set to purple…

If you don’t like that color, you can just change it…

Yes you can but i like purple. :laughing: