Deepin with Muliple Desktop Enviroments

Okay I’m actually using the newly released Deepin UOS on actual hardware.
My issue is at lightdm user login. See I installed a 2nd desktop environment (Cinnamon).
Now when I boot up computer at user login screen default is Cinnamon environment &
I have to click on the Cinnamon icon to switch back to Deepin.

How can I get Deepin as default at login display (my preferred choice)

As I recall, LightDM defaults to the desktop you last accessed, unless you pick another.

Not working that way with Deepin UOS - After last using Deepin environment session my PC still boots up as Cinnamon as default.
For clarification - only a single user profile >> I did not create a 2 user profile for cinnamon desktop environment

you can set this inside lightdm config! ( /etc/lightdm/lightdm.conf )

user-session=deepin.desktop

if i do remember right…

@joekamprad joekamprad

Yup this Deepin-UOS is a strange beast …
Even after specifying [user-session=deepin.desktop] under *seat and saving PC boots up to login display with Cinnamon DE as default.

Anyways that is a minor quirk. My major problem and more pressing is cannot mount my data partition(s) with Deepin-UOS grrrrrrr.
Almost at the point of ripping my hair out … lol
I use the same password as for my user account or terminal commands-- and it it is refused

Please assist

your users password and root password is the same or do you have them different?

My Root and User passwords are exactly the same sir

could be also that deepin greeter is using its own configuration you could see this:
ls /etc/lightdm/

This has got to be a Deepin-UOS bug - As the mounting of NTFS partitions refused happens on two different computers.
I’m using testing repositories in pacman.conf
Everything worked fine with mounting authorization in Deepin ‘DesktopEnvironment’ version 5.11 …

Thanks

Okay managed to auto-mount my separate data hard drive partitions using instructions from:

@ joekampradDer Doktor

could be also that deepin greeter is using its own configuration you could see this:
ls /etc/lightdm/

Terminal output is: [rocky-iv@MSI-EVO-Desktop ~]$ ls /etc/lightdm/
keys.conf lightdm.conf lightdm-gtk-greeter.conf users.conf Xsession

Deepin-UOS just doesn’t provide option-feature to make a single DE as default on boot for user profile when multiple desktop environments are installed

This bug with Cinnamon vs Deepin at LightDM happened to me on the last install I had, too. On this install I loaded Deepin first from the EOS installer, then added Cinnamon later. That has allowed me to choose which DE to go into and it’s sticky, remembering which one I was last in.

1 Like