Deepin is hard to install correctly

I really want to try Deepin, but there is a problem with display managers that I can’t figure out.

Once Deepin is installed the Grub menu appears and the display then goes black and turns off.

I then tried installing EndeavourOS KDE and it worked so I thought to install Deepin alongside KDE and choose Deepin at login.

SDDM (the KDE display manager) does NOT display a choice of DE at login, so I switched to the LightDM display manager. Now when I boot the grub menu appears and the display goes black and turns off.

It really appears like EndeavorOS does not have a working LightDM, at least with my hardware.

DeepinDE is notoriously unreliable, which is why most rolling distros do not ship it as a supported desktop environment.

If you want DeepinDE then you’d be better off using DeepinOS, or picking a KDE theme that makes it look like DeepinDE.

4 Likes

While I agree Deepin is unreliable, this really appears to be a problem with LightDM specifically, not just Deepin.

Why doesn’t LightDM work in EndeavourOS on my PC? I know it works fine with other Distros I have tried.

Did you disable the SDDM service and enable LightDM? You can’t have them both enabled or they will conflict.

2 Likes

It should. If it isn’t, something is wrong.

There are many, many EOS users using lightdm. It is likely something with your configuration.

3 Likes

If you think the problem is with your DM…you can to boot through tty. Crtl-Alt-SomeFNKey and login.

I’m not sure the commamd to start deepin tho…

Maybe startx deepin

But @jonathon is right if you want to use deepin use deepinOS

DeepinOS is great, but they have the most awful forum I’ve ever seen. If I don’t know Chinese I am lost there.

This forum, on the other hand is extremely helpful.

But if it doesn’t work I guess I have no choice. ¯_(ツ)_/¯

I’m convinced this is not just a problem with Deepin.

I installed some of the other Endeavour DEs to see which ones fail. This was the result:

failed Installs:
xfce4
Mate
Gnome
Cinnamon
Budgie
Deepin
i3

installed succesfully:
KDE
LXQT

Clearly my hardware is not going to work well on this distro

I knew I’d seen this recently:

How are you installing them?

  1. boot from usb drive containing iso
  2. start “online” install
  3. choose base install and then DE of choice
  4. shutdown
  5. remove usb drive
  6. boot from hard drive
  7. Wait for Login Manager to appear

Okay I have an update.

I decided to see what would happen if I attached my display to the hdmi port, instead of the display port. Now the all the DEs work fine.

I’ve played with a lot of distros recently and I’ve never seen this before.

1 Like

UbuntuDDE - If you dont wanna use deepinOS

If you want to have a look at Deepin OS live, when the Deepin grub screen appears do,

press: "e"
delete: livecd-installer,
change: locale=us_EN (or your own country's locale),
press: Ctrl+X

and you’d be in the live mode. :slight_smile:

2 Likes

can you report

inxi -Fza
1 Like

output of inxi -Fza:

boot in UEFI[Legacy] is not good
recheck all option in your UEFI

  • SecureBoot off
  • Fast Boot off
  • No CSM
  • No Legacy
  • all disks on AHCI

you can check in terminal

inxi  -Fxza
test -d /sys/firmware/efi && echo efi || echo bios

sudo parted -l  

your disk is GPT , boot on UEFI[Legacy] will try to install in MBR…

4 Likes

Stephane, you are brilliant!

I must admit I’m very surprised the UEFI changes you had me make resolved the DisplayPort issues.

I need to study up on UEFI so I understand it better. I was pretty much ignoring it entirely.

1 Like

If that has it solved - you should mark @Stephane 's post as the Solution…
:grin:

2 Likes

solved :grinning:

1 Like