Decimal values for Syndaemon

The -i value in synadaemon is supposed to alter the time after which the trackpad becomes active again
It does not work, in the sense that neither decimal (0.1) or high (60) values make any change at all. The timeout stays stuck at the default 2 seconds.


I am using syndaemon to stop the trackpad when typing: syndaemon -i 1 -d -R

I would like to set a less great value for -i, such as syndaemon -i 0.1 -d -R for example.
According to the (several spread) documentation the -i parameter defaults to 2.0 seconds. Decimal, hence.
Yet when I set syndaemon -i 0.X -d -R where X is any value between 1 and 9, the daemon just blocks the trackpad for the default 2 seconds. When I use a comma, it complains for invalid values, so I would assume it does understand the dot, it just fails to apply it.

Does someone know what to try next, how to fix, if, or how/where to report, if necessary?

I have tried to find the actual appropriate place to ask and report this issue, found a bug report for something similar in an xFCE instance and I am using Gnome on xOrg.

I tried finding the actual makers of the daemon, it seems it is under the umbrella of x desktop, yet, their (x desktop) doc pages for drivers in general do not mention syndaemon, or synaptics, which by my limited understanding is related.

Thus apologise if this is the wrong place to ask for help with it, it surely feels totally wrong, yet I was informed elsewhere that it would be the best to start with “your distro”, who then would escalate upstream if adequate. And my distro happens to be EOS (T2 modification, however, the problem is not limited to the T2 as far I could test on another computer where I use “vanilla” EOS)

Thank to whomever may inform me where to go next… or how to use decimal values in the -i parameter of the syndaemon?

I don’t know syndaemon but would it help to specify -i 0.Xs ?

You mean to append an s to the value?
It weirdly does not complain about the syntax, but also makes no difference (I think I should feel the difference using -i 0.1, and it rather feels like 2 seconds, despite doing -i 0.1s, although I probably should dicrease the poll time too)

Can I ask what the reasoning of the s is?
seconds, yes, but why append it to an otherwise working decimal? Is this something common in configs? Might save me banging heads in future in other cases knowing more about it


PS: Might be worth to note, -i 0 does not get accepted at all (which is not entirely clear to me why, but it just rejects it and says invalid options where used)
It should be totally fine to disable trackpad while typing and immediately after disabling it… using a poll of 200ms this should still avoid the trackpad becoming active between keystrokes

Duh. Let me correct all that.
No value works at all for the -i param
I just tried to set it to -i 60 and it still reactivates after approx 2 seconds.

Yes, this is what I mean. You should add s for second.

The reason for this is that I thought the tool demands it. :slight_smile:

Hm. Here is the man page:

1 Like

Right - thanks!
It appears to workas well withotu the s

My mistake was pretty silly - it appears that if you have the daemon running (-d) and make changes to the syndaemon over the terminal, those simply have no effect, unless you first kill the daemon.

Not sure why I did not notice this earlier.

Sorry the noise - it appears working as it should.

Good, it works without the trailing s as the man page didn’t directly say that. I only guessed because of the situation you reported, and I took for granted that you had restarted the daemon … :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.