Davinci Resolve AMD GPU Crashing

I hate windows. I hate Microsoft. I feel I was forced there for years. I’ve decided to make the change again. I need davinci resolve to operate professionally. Saw someone say it works on Endeavor OS with AMD GPU.

Installed Davinci, received a blank welcome screen
Closed welcome screen. Relaunched.
Received “Unsupported GPU processing mode” error then quit
Did some reading
Attempted (and perceivably successfully) installed AMD proprietary drivers
Launch Davinci…“Unsupported GPU processing mode” error
Read more
Install AMD OpenCL
Launch Davinci …“Davinci Resolve quit unexpectedly”
Launch Davinci… the app shows for a moment in the task bar then quits without notice
Read more
Several people talk about how Davinci is a nightmare on Linux and you might as well give up
Look up other editing software everything else seems to essentially be a novelty app or broken
Leans back in chair and acknowledges the possibility of being a slave to windows 11

Sapphire 7900 xt

Any advice would be appreciated. I’m sorry if I don’t know how to properly post in order to receive help and will follow directions if given.

Hi there,

To ensure swift and effective assistance, include as much relevant information as possible in your initial post. Spend a few minutes reviewing other posts for formatting inspiration. This will minimize back-and-forth communication and help get you the best support.

Will Kdenlive not work for you?

As far as your error it would be more helpful if we could see the logs. Have you checked with Davinci to see that your meeting all system requirements to run their software.

what is the result of inxi -G (for your graphics)

how did you do that?
The only thing necessary for OpenCL on newer AMD hardware is rocm-opencl-runtime - anything else does not work.

1 Like

Perhaps it would be easier to ask this…

I have
AMD Ryzen 7 5800x
AMD 7900 xt

Let’s say I start with a fresh install. What drivers should I install, in what order (if that matters) with what method? While I primarily use my rig for work purposes I do use it for entertainment from time to time.

EDIT: When it comes to AMD it seems a bit convoluted to me in regard of what packages to install. Should I just install rocm-opencl or additional drivers?

I have read I need to use AMD proprietary drivers if I want things to work properly.

Do I add all packages under section 2 “Installation” of this article?

AMD drivers are only available for Ubuntu directly on their website, is there an Arch package equivalent that exists?

I’ve been trying to locate an in depth guide of exactly how to properly set up an AMD based system with discrete graphics in Arch but I have not located that seems straight forward and well explained. At least to my capabilities and understanding.


  Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX] driver: amdgpu
    v: kernel
  Display: x11 server: X.Org v: 21.1.9 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu resolution:
    1: 2560x1440~60Hz 2: 3840x2160~60Hz
  API: EGL v: 1.5 drivers: radeonsi,swrast
    platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
    renderer: AMD Radeon RX 7900 XT (gfx1100 LLVM 16.0.6 DRM 3.54
  API: Vulkan Message: No Vulkan data available.

there are no real proprietary AMD drivers anymore, they stopped doing those back in 2015. Instead, they develop the drivers that are part of the kernel and mesa and get help in that by Valve, RedHat, Mesa/Kernel-Devs and many others. But for the ease of explanation, I will use “proprietary” in the rest of the post for the package they still offer.

that is a port of the “proprietary” package and it is completely in the AUR so definitely not the recommended solution. It simply exists in the AUR because it can. It is only published by AMD for distributions that don’t get major kernel- and mesa updates, so it is only intended to be used on RHEL/Ubuntu LTS - it basically expands those system’s mesa/kernel with functionality that was added in later versions without upgrading those system parts completely. Last time I looked into it, basically everything in this package was open source - on other systems that get regular kernel- and mesa updates, that package is not necessary. It even has significantly worse performance then what we get on Arch with it’s native packages.

For 90% of the users, you don’t have to do anything because like already explained above, basically everything to get the GPU working is already included in the Kernel package and in the mesa-packages. Just update your whole system regularly and you are golden.

That being said, Vulkan is not installed by default, so you need to install that part of the mesa-packages manually:
sudo pacman -S vulkan-radeon lib32-vulkan-radeon

Now for your special use case of OpenCL. That is not needed by most users so it is also not installed by default. The ROCM packages were created by AMD to work together with both their “proprietary” package and the official mesa-packages. That’s why it is also available in the official repositories. Mesa itself also offers a OpenCL package (opencl-rusticl-mesa and lib32-opencl-rusticl-mesa) but last time I checked those package still had major compatibility issues with most tools that use OpenCL.
You can give them a try with sudo pacman -S opencl-rusticl-mesa lib32-opencl-rusticl-mesa and check if Davinci Resolve works with them. If they don’t, simply remove them with sudo pacman -R opencl-rusticl-mesa lib32-opencl-rusticl-mesa
If that didn’t work, or you want to skip to the AMD-provided OpenCL solution, just do a sudo pacman -S rocm-opencl-runtime
That is actually the same OpenCL-implementation that they ship in their “proprietary” package, so you are using the “proprietary” OpenCL with that.

That’s it. Those are all steps necessary to unlock the full potential of AMD - GPU’s on Linux.

If you wonder why I also tell you to install the 32-bit parts: That is intentional, because there are still many tools, programs and especially games out there that are only 32-bit, those need the 32-bit libraries installed to work.

1 Like

Thank you for the response.

I have tried this and still get a crash on start up
I have read many posts on forums at this point suggesting divinci is a nightmare on linux, and to be completely honest it’s not even that great on windows. Perhaps it is a lost cause.

As I sit right now I have the current packages

Things I have tried and removed

Somewhat unrelated…
As I continue trying to configure my system for daily use I find myself having to apply fixes in order to have things work for example to get my Thinkorswim application to work it required I use…


I then had to set it as default java environment. As these types of solutions occur more regularly, couldn’t solutions for one application become problems for others? Should I keep track of all these ‘fixes’?

did you reboot between each installation / removal?

Can you post the output of pacman -Qs opencl?

Edit: And how did you install davinci resolve? There is an AUR package that also has some comments about crashes:

Maybe those comments help - at least there are some that say davinci resolve crashes with newer kernels - so yeah, looks like a bad piece of software that still needs to be adapted to some change in the Linux Kernel.

If you want to give downgrading the kernel a go, that is done by sudo downgrade linux linux-headers - in the menu, make sure that you choose the same version for both packages - it looks like 6.5.9-arch2 should be the version that still works.

    Simple OpenCL application that enumerates all available platform and device properties
local/libclc 16.0.6-1
    Library requirements of the OpenCL C programming language
local/ocl-icd 2.3.2-1
    OpenCL ICD Bindings
local/opencl-headers 2:2023.04.17-2
    OpenCL (Open Computing Language) header files
local/rocm-opencl-runtime 5.7.1-1
    OpenCL implementation for AMD

I used AUR

yay -S davinci-resolve

This managed to get davinci to launch. Thank you for your help @BS86

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.