Davinci Resolve 18 does not launch

I understand there was a post on a similar issue from April, so I want to be as specific as possible to prevent confusion or redundancy.

I am running the AUR package (though these issues persist with the binary on BMD’s website), in the KDE Plasma DE. I am running an RTX 2080 TI GPU, and have installed Nvidia’s opengl and opencl drivers (nvidia-utils was included in my EOS install). I have also installed the libxcrypt package required on the AUR page, and appear to have a pipewire-ALSA package as well.

Despite all of this, my attempts to launch the software have been fruitless. The software simply crashes a mere second after being clicked, before anything can load. If anyone has any potential fixes for this, it would be greatly appreciated. I have attempted running the binary file in other distributions such as Ubuntu as well, since I’ve previously had plug-and-play success on Debian-based distros, but that wasn’t a win either; so no need to part ways with Endeavor…I already tried.

Could you start it from the command line, and what is the output there?

Also, what version are you running? 18.6? The AUR package is just downloading from the website (version 18.6.2) and installing, so shouldn’t be any different than the package from BMD.

So I found something very curious upon running a search for the package to get the proper name. Nothing showed up. So I tried to just figure out what command the icon on my application launcher is using, and even more peculiarly- the file is only 456 bytes. I’ll look in the folder, but it seems as though the package is not installed despite appearing so on my system

EDIT: sure enough, nothing in the application folder. The file path on the launcher’s entry is to the png file of the icon. But then that would beg the question of what exactly is wrong with the binary

So, to clarify:

You have installed the package from the AUR with DR18.6.2?

When I look to the AUR page, the comment dated 2023-10-23 is talking about issues similar to yours (doesn’t install). The comment dated 2023-10-17 gives a fix to this.

Do you feel comfortable fixing the PKGBUILD manually?

I’ve never fixed a PKGBUILD myself, I don’t suppose I could ask for some help with that?

I would try to assist, but after further looking into this, the fix I mentioned is already in the PKGBUILD now.

Seems like you have to wait for the maintainer to fix the package, it’s already flagged out-of-date. I am also interested in installing it, I let you know when I get a positive result.

EDIT: I tried for myself now, the davinci beta isn’t even installable. After installation of davinci resolve, I tried starting it by hand with /opt/resolve/bin/resolve and get the error message: ./resolve: symbol lookup error: /usr/lib/libpango-1.0.so.0: undefined symbol: g_string_free_and_steal.

After googling this, you can hot fix this by replacing the offending lib with the system one: sudo cp /usr/lib64/libglib-2.0.so.0 /opt/resolve/libs/.

You could also delete the glib stuff from /opt/resolve/libs to make resolve use the system libs automatically, but I didn’t try this.

Afterwards, resolve works. Maybe you need to do a ctrl-c on the first run if you get stuck on a black ‘welcome’ screen.

I have tried to install the beta version of Resolve Studio, and received the following error: ``DaVinci_Resolve_Studio_18.5b4_Linux.zip was not found in the build directory and is not a URL.` Let me know if the free version works for you

I edited my post above with more information Hope this helps.

That did it, tysm!

You’re welcome! Should you intend to work with an SLR camera and Davinci Resolve, please post your experience! This is what I want to do. Any reports for this are helpful.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.