Dark matter Grub theme created an EndeavourOS theme

I found this on our Reddit page and I thought some of you might be interested in it too:


I installed it yesterday; great look! Only thing I changed was the font.

1 Like

Looks almost as good as rEFInd !


But not enough to turn ya? :crazy_face:

Not with what else comes with grub! :grin:

How did you do that?

For example, let’s say you want to use the Hack font size 36 pt. First convert the True Type Font file to pf2:

sudo grub-mkfont --output=/boot/grub/fonts/Hack36.pf2 --size=36 /usr/share/fonts/TTF/Hack-Regular.ttf

And then add the following line to your /etc/default/grub:


You also need to remove the (3) font lines in the theme.txt file it uses.


1 Like

I tried adding the line


to /etc/default/grub and commenting out the 3 font lines in /boot/grub/themes/dark-matter/theme.txt, then running sudo grub-mkconfig -o /boot/grub/grub.cfg and rebooting but the font in grub didn’t change.

I tried doing something similar with the EndeavourOS theme that comes installed with the system but it didn’t work either.

Any ideas why that could be?


I’m new to EndeavourOS and liking it very much so far.

See here:

1 Like

Thank you, @Stagger_Lee. I tried now adding GRUB_FONT to /etc/default/grub and adding the font to theme.txt but it still doesn’t work. It’s interesting though that the font that the kernel uses when it loads after grub is a bigger one than the one it was using before. That makes me think that adding GRUB_FONT does change something but it isn’t visible in the grub menu.

Every example I can find, including in the Arch Wiki, has the paths of GRUB_FONT and GRUB_THEME in quotes.

I tried quoting the values of GRUB_FONT and GRUB_THEME but that didn’t help either.

This is very strange. I wonder if the problem is the font itself. I use terminus, built from sudo grub-mkfont --output=/boot/grub/fonts/terminus18_bold.pf2 /usr/share/fonts/misc/ter-x18b.pcf.gz (not installed by default). I’ve never had an issue using this font with Grub on any distro I’ve used.

I use Hack in GRUB, works fine. So problem is not the font itself.

I’ve tried to replicate this, with my regular system and a VM, and I just can’t.

EDIT: I was able to replicate this, after blowing my system up and starting over. I did exactly what I posted here, but it was still adding the Jetbrains Mono font to /boot/grub/grub.cfg. The secret is this…after you’ve made the theme/grub changes, delete the (2) Jetbrains fonts from the theme folder, then remake grub.

This was driving me nuts! :face_with_symbols_over_mouth:

1 Like

That worked! :partying_face:

Thank you, @ajgringo619!