D-Link DWA-125 wifi adapter going slower on Linux than on Windows

I believe there is an issue with my D-Link wifi-adapter DWA-125 . While it works on EndevourOS, it seems to be having some inconsistency with its connection compared to with Windows 10. (I am dualbooting btw).

I have a Windows game installed on both Windows 10 and on Linux (through wine-staging ). When somebody is downloading, on both Windows and on Linux when I do a speed test they both come up more or less the same results, but on Windows when I play the game (this is while somebody is downloading), it still runs fine, but when I change to Linux and play the same game, while lantency/ping shows up the same as it does on Windows, the character would move glitchup and move and appear in a different place (you know how high latency does to the movement of the character).

I took out my wifi adapter and connected my phone and used USB tethering (USB tethering allows you to share your Internet connection with another computer) and I connected my phone to the same wifi network as I did with the D-Link wifi adapter.

The game on Linux just ran fine then while the other person was running downloads.

So this clearly has got to do with the D-Link wifi adapter not working correctly with Linux. I have tried to change to different kernels (from Xanmod to Zen) and still the same issue.

It may be a firmware problem, but I’ve read about these wifi-usb adapters topics and some are slower on Linux.
Maybe testing on another/usb port can improve?

sudo lspci -vvv

Not a very fast wifi. Are you using it on a N standard or the G?

I could try that the next time somebody is downloading.

The output is over here http://ix.io/2sEg

On Linux it just has some inconsistencies, that is the only issue.

I don’t really know what that means, how would I check, what would be the command for that? I tried to look for it on the back of the wifi adapter’s description there is no indication for this :confused:
edit: I don’t know if it is 802.11 g or 802.11 n

The wifi adapter is capable of N standard but is also backward compatible to G. So it depends on the hardware it’s connecting to. Is your router or wireless connection N or G standard? N is up to 150 Mbps and G is 54 Mbps.

You can check your speed with a download test.

This is my speed on Ethernet because i have fibre optic. On wireless my speed is one tenth of this and i have an N450 adapter. My other adapters are 1900AC and 1300AC so they are much faster because they are dual band 2.4 Ghz and 5.0 Ghz. The N is only 2.4 Ghz single band.

Screenshot_2020-07-29 Speedtest by Ookla - The Global Broadband Speed Test

Edit: This is 1900AC

Screenshot_2020-07-29 Speedtest by Ookla - The Global Broadband Speed Test(1)

The N450 will only be 60Mbps maybe or higher?


I do get less than 54 typically but that is just cause my ISP is bad and I think over wifi there is a lot of loss in speed. The modem was bought a couple of years ago so I suppose it would be N standard. I tried to look at my modem’s back but yeah nothing to indicate if it is N or G.

You got pretty good speeds you are lucky, hardly anyone in my country gets this speed unless you are using some pricey ISP.

My modem does also have dual bands, however my wifi adapter doesn’t support 5 Ghz so I am stuck with 2.4 GHz

It makes a huge difference in how the computer works when its online.

Edit: I don’t find any difference whether I’m on Windows or Linux but i will tell you that it does make a difference depending on the hardware and what chip is on it. Some are just better than others. No question about it. I have the Broadcom chips and my N450 is a realtek i think? I’d have to look. But then again like i say it’s the chip not the name. Some Realtek chips are not great and so are some Broadcom chips or any other brands for that matter.

Yes correct.

So anyways I believe on Linux while it might get the same speeds as it does on Windows, it has some inconsistencies where it will slow down significantly for a second but on various times (when somebody is downloading on the same network) so I was wondering if there is a way to solve this bug with the wifi adapter other than to try and put it in a different USB port?

Edit: I also pasted my pastebin http://ix.io/2sEg

I’m not sure what your set up is. (Same Network)The other computer is also on wireless or wired? You would want to have the wifi if it’s a usb device hooked to the fastest port. The device may only be usb 2.0 anyway but make sure it’s plugged to the faster port. I can’t say whether it will help or not.

1 Like

The other computer also uses wireless.

I will give that a try.

Thanks then.

1 Like