Custom shortcut for changing xkbmap wont work

Hi everyone, Im quite new to i3 and Endeavour but love it so far. But there is one issue I have, thats with changing my keyboard layout with a different Key shortcut than alt+caps. I switch between german and US internat a lot, but also use some “stranger” keyboard layouts like a Corne. I neither do have alt, nor Capslock programmed on that. So I would like to change the keymapping for changing the layouts.

I tried this, but when I press the keys, nothing changes.

exec --no-startup-id setxkbmap -layout 'de,us' -variant altgr-intl,qwerty -option 'grp:Mod4_Space_toggle'

I also tried that with Spaceas space, ctrl+spaceand I guess some others. Lost track a bit tbh. Is there a syntax error in there or can I use only specific keys to change that?

welcome @exen904 :rocket:

to switch (Alt+CAPSLOCK in this example)

it says…

and will need:

local/xorg-setxkbmap 1.3.3-1 (xorg-apps xorg)
    Set the keyboard using the X Keyboard Extension

to be installed.

let my try …

Changing with the default configuration of Alt+Caps works just fine. I just wanted to change the keybinding, because the default one does not work for me.

yes caps lock is strange anyway… i was not writing this in only added it from a Pull Request archwiki say this:

setxkbmap -layout de,us -option grp:win_space_toggle

works for me …

could be

 -variant altgr-intl,qwerty

is giving an error Error loading new keyboard description ?


Thanks for the hint, Ill try again. The strange thing is, I had no issues with that config with the capslock+alt… I just noticed using my sub 60 boards again that the combo is really not good.

Ok I altered the configuration, but also after a reload of the i3 config it still wont work. The entry is now

setxkbmap -layout 'de,us' -variant altgr-intl -option 'grp:$mod_space_toggle'

which works just fine if I enter that in the terminal. But still no change with the key combo.