Cursor Icon gets stuck in wayland

Hey guys I’m running EndeavourOS gnome 43 in wayland at 3840x2160 resolution @ 60 Hz with 200% scaling.
For some reason the mouse cursor Icon gets stuck at random Icon for example in resizing mode. Any idea why this is happening ? I tried to install a different icon theme, but it didn’t make a difference.

Any help would be greatly appreciated.

Screenshot from 2023-01-22 23-28-43

Is this a virtual machine?

no Running it natively on my PC

What is the default icon theme? Have you tried a reset?

its the default Adwaita theme. How do I reset it?

I meant to go back to the default theme, but you said you tried that and it didn’t help.

correct, not sure why its acting like that

This seems similar to this issue

Even if not the exactly same this is likely something with mutter, have you tried it without 200% scaling?

Thanks!, turning off the zoom fixed the issue. definitely a bug with wayland


it also happens in X11 under certain circumstances so its something to do with some sort of mutter bug in general :man_shrugging:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.