CUPS Driver not installing properly

I have been having issues with CUPS driver I removed them and then reinstalled them, but nothing seems to have been working. I am using KDE.

                     ./o.                  rolex@rolex-pc 
                   ./sssso-                -------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: XPS 15 9560 
             `-/ossssssssssssso/.          Kernel: 5.9.9-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 4 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 1338 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: zsh 5.8 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080 
    .:///ossssssssssssssssssssssssso++:    DE: Plasma 5.20.3 
  `:////ssssssssssssssssssssssssssso+++.   WM: KWin 
`-////+ssssssssssssssssssssssssssso++++-   WM Theme: WhiteSur-dark 
 `..-+oosssssssssssssssssssssssso+++++/`   Theme: WhiteSurDark [Plasma], Breeze [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Icons: WhiteSur-dark [Plasma], WhiteSur-dark [GTK2/3] 
  `:::::::::::::::::::::::::------``       Terminal: konsole 
                                           CPU: Intel i7-7700HQ (8) @ 3.800GHz 
                                           GPU: NVIDIA GeForce GTX 1050 Mobile 
                                           GPU: Intel HD Graphics 630 
                                           Memory: 3087MiB / 15857MiB 

                                                                   
                                                                   


 rolex  rolex-pc  ~  %  sudo systemctl enable org.cups.cupsd.service
Failed to enable unit: Unit file org.cups.cupsd.service does not exist.
 rolex  rolex-pc  ~  ERROR  %  sudo systemctl start org.cups.cupsd.socket
Failed to start org.cups.cupsd.socket: Unit org.cups.cupsd.socket not found.
 rolex  rolex-pc  ~  5  %  sudo systemctl enable org.cups.cupsd.socket
Failed to enable unit: Unit file org.cups.cupsd.socket does not exist.

1 Like

The new way to enable cups is simply sudo systemctl enable cups.service

This fixed it for me. Thank you for the help mate!

 rolex  rolex-pc  ~  %   sudo systemctl enable cups.service
 rolex  rolex-pc  ~  %   sudo systemctl start cups.service 

1 Like

Wasn’t this issue extensively covered and this fix quoted here?


:thinking:

4 Likes

Hummm, someone mentioned this 4 or 5 days ago in a YouTube chat, so I went to the Archlinux.org, there was nothing mentioned on the “Lastest News” section on this issue. :thinking:
I have not see this on any of my Arch OS flavors. Maybe I’m lucky… Usually not! Lol
I will keep this post in mind just in case… :slight_smile:
Thanks for the posting!
LLAP

1 Like