CS:GO Crashes on Map Loading

The game crashes when loading any map and any game mode whether it is deathmatch, competitive or other at “Retrieving Game Data…” I tried verify integrity of game files, it reacquires 1 file of size 98.6KB. I also restarted my computer and fully uninstalled CS:GO and reinstalled it even deleted my config, still no luck on getting in match. After some digging in the logs I found that ~/.local/share/Steam/steamapps/common/Counter-Strike Global Offensive/csgo/maps/soundcache/_master.cache is the file being re-downloaded when I verify game files. This issue has been persisting since May. I am on nvidia and XFCE.

I think it may be generated with the map loading up, to store various ambient noises for maps. Try to join without redownloading it? (unfortunately CS:GO is the only game in the source lineup that doesn’t allow you to disable ambient noise)

Make sure you’re not playing with Proton. Afaik VAC kicks Proton users no warning, since the game is supported natively.

You may also want to try to clear out your Steam Cloud data for CS:GO, though I doubt that soundcache would be stored there.

If you can’t find a solution. It might be wise to contact Steam technical support. Since it’s a game specific issue, they’d take it seriously.

I know it is a Linux native title but try again with proton enabled.

1 Like

IIRC on a video with CS:GO benchmarks with Proton it was explicitly said it was a benchmark and that VAC wouldn’t allow you to connect, especially to competitive games.

https://www.protondb.com/app/730 – Seems to report the same.

There’s also a few solutions there worth checking out too.

If I join without re-downloading the file I get booted at “retrieving game data…” whether it is an offline workshop map or an online match.

I am running the native non-proton version.

I did contact the steam support and they told me to open an issue on github as they do not support Linux which I did. My issue has been opened since May 21 and not a single reply from a dev.

1 Like

I’ll load this up tonight and report back…


I’m gonna download the game as well and see how it goes for me. Haven’t played since Closed Beta.

I think I have a very similar setup to you.

1 Like

The game seems to run fine. Did a couple rounds of Deathmatch on Dust 2, turns out I’m awful at CS nowdays (couldn’t get out of 4th place in any of the games lol). I can reboot, relaunch the game and play just fine.

I ran it natively, with everything on low, Anti-Aliasing 2x and Global Shadows on high, default audio settings, it would hang on a black screen without “-nojoy” in launch options, Fullscreen doesn’t work, Windowed Fullscreen seems to work fine, the game occasionally stutters or has inconsistent sound sometimes – though those things seem to be the game itself.

Proton 4.11, 5.0-9, 5.9-GE all seem to crash on launch.

I have a R3 2200G, AsRock AB350M Pro4 with latest BIOS, 1060 6GB with drivers at 455.23.04, my kernel is 5.8.10.arch1-1.

Verifying game integrity downloads 2 files, one if them is _master.cache, loading into a map the file always gets deleted and everything works fine. Verifying game integrity after playing always downloads it again.

Looking at Steam Cloud data, there is some caching stored in there. Could be relevant to what gets downloaded. But I highly doubt _master.cache has to do anything with it. If anything, it could be your various configs for settings and if you delete them, instead of getting defaults, you get your Cloud backup ones.

1 Like

I don’t think the issue lies within the config as I have completely deleted and launched with the default I still can’t get in a match even offline with bots and workshop. I just tried now.

I am using a ryzen 9 3900x with 32gb 3600mhz and an rtx 2070.