Create btrfs subvol for /home

The installer didn’t create a @home for my home partition, for reasons not yet clear to me. Everything is working fine, but since it’s btrfs, shouldn’t home be in a subvolume? How can I create one now? I’ve done a lot of searching and some of what I’ve found seems either contradictory or very complicated.

give us a little hint by providing the installer logs:
sudo cat /var/log/endeavour-install.log | eos-sendlog

Installe ris set to create a subvolume for home… as long as you do not amnually change the install process.

thats the used scheme…

If you put /home on it’s own partition, it won’t create a subvolume.

This is easy to fix.

  • Take a read/write snapshot of /home named /home/@home
  • Edit /etc/fstab and change the mount for /home to this new subvolume
  • Test it with sudo mount /home and verify that the mount is correct
  • reboot
  • Once everything is working properly. You can delete the old data.

did overread this one indeed… :wink:

Thanks Joe. :wink: dalto, I think I’m stuck at your first bullet. I’ve read that you can only take snapshots of subvolumes, which of course my /home is not yet. Can you help me with exactly how to do that?

sudo btrfs subvolume snapshot /home /home/@home

Sorry, I guess I need help with the fstab.
The snapshot was created in /home, so now in /home is @home and dave.
UUID=adfcd37e-a3a3-4292-b86d-fbc745610698 /home btrfs subvol=/home/@home,noatime,compress=zstd 0 0
…and without the /home in <options>. Tired of restoring the backup in emergency mode. :slight_smile:

It is just subvol=@home

Awesome, almost there. Seems to be working properly, btrfs subvolume list /home now shows @home and it shows up in btrfs-assistant. Last question, I hope. Final bullet… where is the old data?!

It isn’t mounted anywhere.

You need to mount that device at /mnt (or anywhere else you prefer)

Don’t pass a subvol option and it should mount the root.

When you look in /mnt you should see @home and dave.

Don’t touch @home. You should be able to delete dave. Then unmount it from /mnt

That being said, it is not urgent to do this right away if you would prefer to wait.

Makes sense. I have a lot to learn. Thanks!

1 Like

Consider clicking on the solved button under the post which helped you solve the issue, instead of changing the title to solved.
It looks like this:

It helps the forum software recognize that post as the solution and recommends that solution to other users if they search for the same issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.